php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #60645 PHP 5.3 (VC9) does work(flawlessly) with apache.org binaries.
Submitted: 2012-01-03 18:44 UTC Modified: 2014-03-31 07:23 UTC
Votes:8
Avg. Score:3.9 ± 0.9
Reproduced:7 of 7 (100.0%)
Same Version:5 (71.4%)
Same OS:5 (71.4%)
From: notebooksource at gmail dot com Assigned: ab (profile)
Status: Closed Package: Website problem
PHP Version: 5.3.8 OS: Windows 7
Private report: No CVE-ID: None
 [2012-01-03 18:44 UTC] notebooksource at gmail dot com
Description:
------------
The download page states "Do Not use VC9 versions with apache.org binaries...".
It states that you should get apache binaries from the Apache Lounge if you're 
going to use a VC9 version.
I tried many times to get PHP 5.2.17 to work with an apache2.2.21 binary from 
apache.org on Windows 7.
I didn't want to use 5.2.17 because it's no longer supported,but I had used it 
before, and I didn't want to use the apache binary from Apache Lounge,because when 
I looked at the install instructions ,I saw the words "Make" and "build".
I compiled and installed PHP from source code once, but I'm never going to do it 
again.
So, in my frustration, I just decided to TRY PHP 5.3.8 (VC 9) with the apache 
2.2.21 binary from apache.org and it works flawlessly. I realize that Windows 7 
natively supports the VC9 version, but the instructions on the download page led 
me to beleive that the issue was with the apache.org binary.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-02-17 01:01 UTC] salisbm at hotmail dot com
I'm seeing a similar but different issue.  Because current windows php 
distributions (built with vc9 binaries) no longer work with standard apache.org 
distributions (built with vc6), I've tried to follow the instructions and get 
apache from apache lounge.  (As mentioned on http://windows.php.net/download/).

However, the apache lounge version does not work either!

C:\Apache2\bin>httpd
httpd: Syntax error on line 494 of C:/Apache2/conf/httpd.conf: Can't locate API 
module structure `php5_module' in file D:/php/php-5.3.10/php5.dll: No error
 [2012-02-17 01:29 UTC] salisbm at hotmail dot com
Update - I tried using the non-thread safe PHP vc9 binaries originally.
I tried again using the thread safe PHP vc9 binaries and they worked!

http://windows.php.net/ states:
"If you are using PHP with Apache 1 or Apache2 from apache.org you need to use 
the VC6 versions of PHP

If you are using PHP with IIS you should use the VC9 versions of PHP VC6 
Versions are compiled with the legacy Visual Studio 6 compiler VC9 Versions are 
compiled with the Visual Studio 2008 compiler and have improvements in 
performance and stability. The VC9 versions require you to have the Microsoft 
2008 C++ Runtime (x86) or the Microsoft 2008 C++ Runtime (x64) installed

Do NOT use VC9 version with apache.org binaries

VC9 versions of Apache can be fetched at Apache Lounge. We use their binaries to 
build the Apache SAPIs."

**************
It does not mention that the thread safe PHP vc9 binaries must be used to work 
with apache from Apache Lounge.
**************
 [2013-12-23 05:42 UTC] bjori@php.net
-Package: Documentation problem +Package: Website problem -Assigned To: +Assigned To: ab
 [2014-03-31 07:23 UTC] ab@php.net
-Status: Assigned +Status: Closed
 [2014-03-31 07:23 UTC] ab@php.net
Note about the TS versions usage added to the site. That is however not an excuse for users to read other docs, like Apache ones which tell that mpm_winnt is threads based ;)
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Aug 03 21:01:24 2020 UTC