php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #60467 About 107 auto test [phpt script] failed .
Submitted: 2011-12-08 03:34 UTC Modified: 2013-06-26 16:57 UTC
Votes:2
Avg. Score:4.0 ± 1.0
Reproduced:2 of 2 (100.0%)
Same Version:1 (50.0%)
Same OS:1 (50.0%)
From: Jtang at suse dot com Assigned:
Status: Not a bug Package: Testing related
PHP Version: 5.3.8 OS: SLES 11 SP2
Private report: No CVE-ID: None
 [2011-12-08 03:34 UTC] Jtang at suse dot com
Description:
------------
I use the phpt file from php 5.3 tarball package for automation test.

11338 test file , 107 failed , 

in 107 failed :
   # 33 test are expect as described in output
   # 9 test have bug NO.
   # 66 test is failed

66 test cases are:
./ext/calendar/tests/easter_date.phpt
./ext/calendar/tests/unixtojd.phpt
./ext/date/tests/DateTime_days-spring-type2-type2.phpt
./ext/date/tests/DateTime_days-spring-type2-type3.phpt
./ext/date/tests/DateTime_days-spring-type3-type2.phpt
./ext/date/tests/DateTime_days-spring-type3-type3.phpt
./ext/date/tests/DateTime_sub-dates.phpt
./ext/date/tests/DateTime_sub-february.phpt
./ext/date/tests/timezone_location_get.phpt
./ext/dom/tests/DOMDocument_relaxNGValidate_error2.phpt
./ext/dom/tests/DOMDocument_validate_on_parse_variation.phpt
./ext/gmp/tests/gmp_nextprime.phpt
./ext/intl/tests/resourcebundle_arrayaccess.phpt
./ext/intl/tests/resourcebundle_individual.phpt
./ext/intl/tests/resourcebundle_iterator.phpt
./ext/mysql/tests/001.phpt
./ext/mysql/tests/mysql_connect.phpt
./ext/mysql/tests/mysql_max_links.phpt
./ext/mysql/tests/mysql_sql_safe_mode.phpt
./ext/mysqli/tests/mysqli_connect.phpt
./ext/mysqli/tests/mysqli_connect_oo.phpt
./ext/mysqli/tests/mysqli_connect_oo_defaults.phpt
./ext/pcre/tests/006.phpt
./ext/pdo_mysql/tests/pdo_mysql___construct_options.phpt
./ext/pdo_mysql/tests/pdo_mysql_interface.phpt
./ext/posix/tests/posix_ttyname_error.phpt
./ext/posix/tests/posix_ttyname_variation1.phpt
./ext/posix/tests/posix_ttyname_variation2.phpt
./ext/posix/tests/posix_ttyname_variation3.phpt
./ext/posix/tests/posix_ttyname_variation4.phpt
./ext/posix/tests/posix_ttyname_variation5.phpt
./ext/posix/tests/posix_ttyname_variation6.phpt
./ext/posix/tests/posix_ttyname_variation7.phpt
./ext/session/tests/014.phpt
./ext/session/tests/015.phpt
./ext/session/tests/018.phpt
./ext/session/tests/020.phpt
./ext/session/tests/021.phpt
./ext/session/tests/session_id_variation2.phpt
./ext/sockets/tests/socket_strerror.phpt
./ext/spl/examples/tests/dualiterator_001.phpt
./ext/sqlite/tests/sqlite_session_001.phpt
./ext/sqlite/tests/sqlite_session_002.phpt
./ext/sqlite3/tests/sqlite3_prepare_001.phpt
./ext/standard/tests/class_object/is_a_error_001.phpt
./ext/standard/tests/class_object/is_subclass_of_error_001.phpt
./ext/standard/tests/general_functions/getservbyname_variation10.phpt
./ext/standard/tests/general_functions/getservbyname_variation9.phpt
./ext/standard/tests/general_functions/getservbyport_variation1.phpt
./ext/standard/tests/general_functions/phpinfo.phpt
./ext/standard/tests/general_functions/proc_nice_variation5.phpt
./ext/standard/tests/misc/time_sleep_until_basic.phpt
./ext/standard/tests/php_ini_loaded_file.phpt
./ext/standard/tests/strings/htmlentities02.phpt
./ext/standard/tests/strings/htmlentities04.phpt
./ext/standard/tests/strings/htmlentities10.phpt
./ext/standard/tests/strings/htmlentities11.phpt
./ext/standard/tests/strings/htmlentities13.phpt
./ext/standard/tests/strings/htmlentities15.phpt
./ext/standard/tests/strings/setlocale_variation2.phpt
./ext/xsl/tests/xslt010.phpt
./ext/xsl/tests/xsltprocessor_registerPHPFunctions-funcnostring.phpt
./ext/xsl/tests/xsltprocessor_registerPHPFunctions-funcundef.phpt
./sapi/cli/tests/001.phpt
./sapi/cli/tests/015.phpt





    

Test script:
---------------
only one line script

env TEST_PHP_EXECUTABLE=/usr/bin/php REPORT_EXIT_STATUS=1 TEST_PHP_SRCDIR=/usr/share/qa/qa_test_php53 TEST_PHP_DETAILED=1 NO_INTERACTION=1 /usr/bin/php -d 'open_basedir=' -d 'output_buffering=0' -d 'memory_limit=-1' /usr/share/qa/qa_test_php53/run-tests.php [phpt.file]

Expected result:
----------------
65 test cases should pass?

Actual result:
--------------
65 test cases failed

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-12-09 14:13 UTC] danielc@php.net
I'll deal with the ext/date/tests portions in the near future.
 [2013-06-26 16:30 UTC] mi+php at aldan dot algebra dot com
In the cases, where the errors are related to DateTime, the differences seem to have to do with daylight-saving time. Note the EST vs. EDT differences in the lines reported by the test-failures:

DateTime_add-spring-type2-type3.diff
...
008+ test_time_spring_type2_st_type3_post: ADD: 2010-03-14 00:10:20 EST + P+0Y0M1DT18H49M39S = **2010-03-15 18:59:59 EST**
009+ test_time_spring_type2_dt_type3_prev: ADD: 2010-03-14 03:16:55 EDT + P-0Y0M0DT7H38M27S = **2010-03-13 19:38:28 EDT**
008- test_time_spring_type2_st_type3_post: ADD: 2010-03-14 00:10:20 EST + P+0Y0M1DT18H49M39S = **2010-03-15 19:59:59 EDT**
009- test_time_spring_type2_dt_type3_prev: ADD: 2010-03-14 03:16:55 EDT + P-0Y0M0DT7H38M27S = **2010-03-13 18:38:28 EST**

It is likely, the build-machine's TZ-definitions aren't up to date -- daylight savings really did begin on March 14th in 2010:

http://www.timeanddate.com/time/dst/2010.html
 [2013-06-26 16:57 UTC] sixd@php.net
-Status: Open +Status: Not a bug
 [2013-06-26 16:57 UTC] sixd@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately you are not using a current version of PHP -- 
the problem might already be fixed. Please download a new
PHP version from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.

----

Please try PHP 5.5.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sat May 08 05:01:23 2021 UTC