php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #60390 Missing _SERVER[SERVER_PORT]
Submitted: 2011-11-25 20:16 UTC Modified: 2011-11-25 21:18 UTC
From: fabien+php at pennequin dot me Assigned: pajoye
Status: Closed Package: Built-in web server
PHP Version: 5.4.0RC2 OS: Mac OS X 10.7
Private report: No CVE-ID:
 [2011-11-25 20:16 UTC] fabien+php at pennequin dot me
Description:
------------
The _SERVER[SERVER_PORT] variable is missing with the php built-in server.
This is useful for generate full URLs and it's used by some php frameworks.



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-11-25 21:18 UTC] pajoye@php.net
Automatic comment from SVN on behalf of pajoye
Revision: http://svn.php.net/viewvc/?view=revision&revision=319846
Log: - implement FR #60390, SERVER_PORT missing
 [2011-11-25 21:18 UTC] pajoye@php.net
This bug has been fixed in SVN.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.

 For Windows:

http://windows.php.net/snapshots/
 
Thank you for the report, and for helping us make PHP better.


 [2011-11-25 21:18 UTC] pajoye@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: pajoye
 [2011-11-25 21:21 UTC] pajoye@php.net
Automatic comment from SVN on behalf of pajoye
Revision: http://svn.php.net/viewvc/?view=revision&revision=319849
Log: - FR #60390
 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Sat Apr 19 22:02:16 2014 UTC