php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #60361 Installation involving --enable-solr-debug always enables SOLR_DEBUG
Submitted: 2011-11-22 21:12 UTC Modified: 2015-01-10 21:51 UTC
Votes:1
Avg. Score:4.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:1 (100.0%)
From: eric at linkup dot com Assigned: omars (profile)
Status: Closed Package: solr (PECL)
PHP Version: 5.3.8 OS: Ubuntu 11.04
Private report: No CVE-ID: None
 [2011-11-22 21:12 UTC] eric at linkup dot com
Description:
------------
During a standard "pecl install solr", it asks if debugging should be on (defaulting to "no"). However, "./configure --enable-solr-debug=no" always triggered SOLR_DEBUG to be 1. This is because the config.m4 file does not pay attention to if a value is after the "enable-solr-debug" command.

(SOLR_DEBUG's status because relevant because of the "Deleted last value from parameter" E_NOTICE thrown via line 1052 of solr_functions_params.c, which is the subject of another bug report.)

The attached config.m4 patch follows the suggested method in internals2.buildsys.configunix.php regarding the handling of ARG_ENABLE.

Test script:
---------------
./configure --enable-solr-debug=no

Expected result:
----------------
SOLR_DEBUG is not defined, SOLR_DEBUG_OFF is.

Actual result:
--------------
SOLR_DEBUG is defined, SOLR_DEBUG_OFF is not.

Patches

config.m4.patch (last revision 2011-11-22 21:13 UTC by eric at linkup dot com)

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-06-11 14:12 UTC] felipe@php.net
-Status: Open +Status: Assigned -Assigned To: +Assigned To: iekpo
 [2014-06-22 13:41 UTC] omars@php.net
-Assigned To: iekpo +Assigned To: omars
 [2014-06-22 13:49 UTC] omars@php.net
confirmed, fixed in 2.0.0
 [2015-01-10 21:51 UTC] omars@php.net
-Status: Assigned +Status: Closed
 [2015-01-10 21:51 UTC] omars@php.net
Fixed version 2.0.0
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Nov 29 01:03:14 2021 UTC