php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #60239 Subtle httpd.conf "include wildcard" directive worthy of note
Submitted: 2011-11-07 20:49 UTC Modified: 2011-12-03 23:14 UTC
From: csm at forus dot com Assigned:
Status: Wont fix Package: Documentation problem
PHP Version: Irrelevant OS: CentOS 6
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2011-11-07 20:49 UTC] csm at forus dot com
Description:
------------
For one confused comparing systems and/or setting up a new one (and thus coming to these docs), the subtle wildcard directive "Include conf.d/*.conf" can mislead and thus is worthy of special note. At minimal this specific directive is employed in CentOS 6's powerful, but mysterious, "web sever" install with PHP.

Specifically, in http://www.php.net/manual/en/install.unix.apache2.php step 7 notes refer to changes to make in httpd.conf. When searching for something like "php" in httpd.conf to follow your setup, one may draw false conclusions about what they have if they are not aware of the subtle "Include conf.d/*.conf" line - which may load a "php.conf".

Your docs are great, and very appreciated. But if you do not object I suggest that a mention of the powerful "include wildcard" directive somehow adjunct to mention of "httpd.conf" would be worthwhile to those arriving in need (which is most of us).

Thanks,
Cris Mooney



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-12-03 23:14 UTC] frozenfire@php.net
-Status: Open +Status: Wont fix
 [2011-12-03 23:14 UTC] frozenfire@php.net
While I agree that some may endure a bit of confusion if they're not familiar 
with CentOS's way of writing httpd.conf, I do not feel it's a good idea to 
include that in the PHP manual.

The directions for setting PHP up in Apache on Unix-based systems are general to 
most all systems. Since CentOS is an enterprise system by design, one should 
expect that anyone administrating it will be familiar with the relevant 
directives, and how CentOS does things.

To include those directions may add additional confusion for those who aren't 
using CentOS.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Wed May 22 19:01:31 2024 UTC