php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #60231 child process exited with status 3221225725
Submitted: 2011-11-07 10:42 UTC Modified: 2013-05-27 15:17 UTC
Votes:5
Avg. Score:5.0 ± 0.0
Reproduced:4 of 4 (100.0%)
Same Version:3 (75.0%)
Same OS:2 (50.0%)
From: mausglov at yandex dot ru Assigned:
Status: Not a bug Package: Reproducible crash
PHP Version: 5.3.8 OS: Windows 7 Ultimate
Private report: No CVE-ID: None
 [2011-11-07 10:42 UTC] mausglov at yandex dot ru
Description:
------------
Apache crashes after submitting the form. On smaller content of textarea the bug disappears.

httpd.exe: 2.2.17.0 , running as application
exception code: 0xc00000fd
error offset: 0x0018a7a3

php5ts.dll 5.3.8.0
extensions:
extension=php_gd2.dll
extension=php_mbstring.dll
extension=php_mysql.dll
extension=php_mysqli.dll
extension=php_pdo_mysql.dll


Test script:
---------------
http://pastebin.com/dg38zb5J


Expected result:
----------------
print_r() show me $_REQUEST, converted to utf-8

Actual result:
--------------
Connection aborted, Windows says something like "Application closed"

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-11-16 11:33 UTC] felipe@php.net
-Status: Open +Status: Feedback
 [2011-11-16 11:33 UTC] felipe@php.net
Thank you for this bug report. To properly diagnose the problem, we
need a backtrace to see what is happening behind the scenes. To
find out how to generate a backtrace, please read
http://bugs.php.net/bugs-generating-backtrace.php for *NIX and
http://bugs.php.net/bugs-generating-backtrace-win32.php for Win32

Once you have generated a backtrace, please submit it to this bug
report and change the status back to "Open". Thank you for helping
us make PHP better.


 [2011-11-17 19:18 UTC] mausglov at yandex dot ru
Full call stack here: http://pastebin.com/HC5Gcthu

short version:
Function     Arg 1     Arg 2     Arg 3     Arg 4   Source 
php5ts!match+23     0288d97b     01eb2270     0288d740     00000000   d:\php-sdk\snap_5_3\vc9\x86\php-5.3.8\ext\pcre\pcrelib\pcre_exec.c @ 649 
php5ts!match+881a     0288d97b     01eb226d     0288d740     00000000   d:\php-sdk\snap_5_3\vc9\x86\php-5.3.8\ext\pcre\pcrelib\pcre_exec.c @ 886 + 35 
php5ts!match+899e     0288d979     01eb2294     0288d740     00000000   d:\php-sdk\snap_5_3\vc9\x86\php-5.3.8\ext\pcre\pcrelib\pcre_exec.c @ 1654 + 2a 

----- previuos 2 lines repeated 308 times ----

php5ts!match+881a     0288d740     01eb226d     0288d740     00000000   d:\php-sdk\snap_5_3\vc9\x86\php-5.3.8\ext\pcre\pcrelib\pcre_exec.c @ 886 + 35 
php5ts!match+aee     0288d740     01eb2268     0288d740     00000000   d:\php-sdk\snap_5_3\vc9\x86\php-5.3.8\ext\pcre\pcrelib\pcre_exec.c @ 1515 + 2f 
php5ts!php_pcre_exec+afb     01eb2240     027ff814     0288d740     000002c7   d:\php-sdk\snap_5_3\vc9\x86\php-5.3.8\ext\pcre\pcrelib\pcre_exec.c @ 6099 + 3f 
php5ts!php_pcre_match_impl+239     01eb2710     0288d740     000002c7     0288d370   d:\php-sdk\snap_5_3\vc9\x86\php-5.3.8\ext\pcre\php_pcre.c @ 629 
php5ts!php_do_pcre_match+a8     00000002     00000002     028925e8     028c0988   d:\php-sdk\snap_5_3\vc9\x86\php-5.3.8\ext\pcre\php_pcre.c @ 520 + 2b 
php5ts!zif_preg_match+17     00000002     0288d370     00000000     00000000   d:\php-sdk\snap_5_3\vc9\x86\php-5.3.8\ext\pcre\php_pcre.c @ 771 + 17 
php5ts!zend_do_fcall_common_helper_SPEC+920     028c0988     01dfba00     01dfbae8     028c0988   d:\php-sdk\snap_5_3\vc9\x86\php-5.3.8\zend\zend_vm_execute.h @ 320 + 41 
php5ts!ZEND_DO_FCALL_SPEC_CONST_HANDLER+11a     00000000     01e80618     01dfbae8     0288e630   d:\php-sdk\snap_5_3\vc9\x86\php-5.3.8\zend\zend_vm_execute.h @ 1640 + e 
php5ts!execute+2e8     0288ecd0     01dfba01     00000000     027ffac8   d:\php-sdk\snap_5_3\vc9\x86\php-5.3.8\zend\zend_vm_execute.h @ 107 + a 
php5ts!zend_call_function+8c9     00000000     01e8063c     028c0370     027ffaa4   d:\php-sdk\snap_5_3\vc9\x86\php-5.3.8\zend\zend_execute_api.c @ 968 + 1b 
php5ts!php_array_walk+2e2     0288e138     027ffac8     00000001     01dfbae8   d:\php-sdk\snap_5_3\vc9\x86\php-5.3.8\ext\standard\array.c @ 1115 + 1f 
php5ts!php_array_walk+1d0     0288d0d0     027ffac8     00000001     01dfbae8   d:\php-sdk\snap_5_3\vc9\x86\php-5.3.8\ext\standard\array.c @ 1094 
php5ts!zif_array_walk_recursive+101     00000003     0288d2e8     00000000     00000000   d:\php-sdk\snap_5_3\vc9\x86\php-5.3.8\ext\standard\array.c @ 1186 
php5ts!zend_do_fcall_common_helper_SPEC+920     028c0370     01dfba00     01dfbae8     028c0370   d:\php-sdk\snap_5_3\vc9\x86\php-5.3.8\zend\zend_vm_execute.h @ 320 + 41 
php5ts!ZEND_DO_FCALL_SPEC_CONST_HANDLER+11a     01dfbae8     027ffbe4     00000000     027ffe70   d:\php-sdk\snap_5_3\vc9\x86\php-5.3.8\zend\zend_vm_execute.h @ 1640 + e 
php5ts!execute+2e8     0288c2a8     01dfba00     01dfbae8     00000000   d:\php-sdk\snap_5_3\vc9\x86\php-5.3.8\zend\zend_vm_execute.h @ 107 + a 
php5ts!zend_execute_scripts+fe     00000008     01dfbae8     00000000     00000003   d:\php-sdk\snap_5_3\vc9\x86\php-5.3.8\zend\zend.c @ 1237 
php5ts!php_execute_script+24c     027ffe70     01dfbae8     00000004     013510a8   d:\php-sdk\snap_5_3\vc9\x86\php-5.3.8\main\main.c @ 2284 + 12 
php5apache2_2!php_handler+634     01df3b28     01df3b28     0090f628     6eecd540   d:\php-sdk\snap_5_3\vc9\x86\php-5.3.8\sapi\apache2handler\sapi_apache2.c @ 669 + e 
libhttpd!ap_run_handler+25     00000000     00000000     00000000     00000000
 [2011-11-17 19:18 UTC] mausglov at yandex dot ru
-Status: Feedback +Status: Open
 [2011-11-17 19:24 UTC] mausglov at yandex dot ru
For Windows XP SP3 ( the debug report was made in this OS ) exit statuses are different:
4294967295 - with DebugDiag;
3221225477 - without
 [2013-05-23 10:10 UTC] frank dot ralf at comm-press dot de
There's a thorough investigation into the string length problem mentioned in the bug report at http://www.apachefriends.org/f/viewtopic.php?f=16&t=48914&p=207571#p201370
 [2013-05-27 15:11 UTC] frank dot ralf at comm-press dot de
The solution is increasing the ThreadStackSize from 1 MB (default under Windows) to 8 MB (default under Linux), see http://stackoverflow.com/questions/5058845/how-do-i-increase-the-stack-size-for-apache-running-under-windows-7 for details.
 [2013-05-27 15:17 UTC] pajoye@php.net
it can be done using the apache configuration or using editbin.
 [2013-05-27 15:17 UTC] pajoye@php.net
-Status: Open +Status: Not a bug
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sun Nov 27 18:03:43 2022 UTC