php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #60132 Additional optional parameter for sybase_connect
Submitted: 2011-10-25 15:07 UTC Modified: 2015-02-18 07:45 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: f dot bischof at dbap dot de Assigned:
Status: Wont fix Package: Sybase-ct (ctlib) related
PHP Version: 5.3.8 OS: Linux
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2011-10-25 15:07 UTC] f dot bischof at dbap dot de
Description:
------------
---
From manual page: http://www.php.net/function.sybase-connect
---
We need an additional parameter for the sybase_connect function: Databasename

Like this:

resource sybase_connect ([ string $servername [, string $username [, string $password [, string $charset [, string $appname [, bool $new = false ][, string $Databasename ]]]]]])

If you have specified a default databasename "database1" at the sybase-server and the database has the following users: "user1", "user2" but you have also a database "database2" with "user3" and "user4", you have no chance to connect to "database2" with "user3".

Following errors appear:
sybase_connect(): Sybase:  Unable to connect in ...
sybase_select_db(): supplied argument is not a valid Sybase-Link resource in ...

Because of some backup/restore behavior we have to define a default database! It would be a nice feature to add the "databasename" to the sybase_connect:-) 


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-02-18 07:45 UTC] krakjoe@php.net
-Status: Open +Status: Wont fix
 [2015-02-18 07:45 UTC] krakjoe@php.net
The sybase maintainer has backed away from the project, since nobody new has come forward it has been removed in version 7 of PHP.

For this reason, I'm marking the bug as won't fix, it can still be found by any maintainer that might come along and revive sybase as a PECL project.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sat May 25 01:01:26 2019 UTC