php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #6 Cannot connect to remote Oracle machine
Submitted: 1998-01-26 16:09 UTC Modified: 1998-01-29 07:53 UTC
Votes:3
Avg. Score:4.3 ± 0.5
Reproduced:0 of 1 (0.0%)
From: kennh at sierra dot com Assigned:
Status: Closed Package: Oracle related
PHP Version: 3.0b3 OS: Solaris
Private report: No CVE-ID: None
 [1998-01-26 16:09 UTC] kennh at sierra dot com
I am not sure if this is a bug or if I am doing something,
wrong.  Here is the email that I previously sent to the
email list:

I am banging my head against the wall on this one.  How do I need to set
the environmental variables to connect to a remote Oracle machine? Note
that the actual machine is behind a firewall, but I have a static IP route
to it.

I have already tried:

PutEnv("ORACLE_HOME=/db/oracle7/");
PutEnv("ORACLE_SID=WG73"); 
PutEnv("WGSHOST=dbmachine.foo.com");

and:

PutEnv("ORACLE_HOME=/db/oracle7/");
PutEnv("ORACLE_SID=WG73@dbmachine.foo.com");

and:

PutEnv("ORACLE_HOME=/db/oracle7/");
PutEnv("ORACLE_SID=WG73_tcp_dbmachine.foo.com");

and:

PutEnv("ORACLE_HOME=/db/oracle7/");
PutEnv("ORACLE_SID=WG73_tcp@dbmachine.foo.com");


but none seem to work.  


Thanks,

Kenn Herman
Assistant Technical Webmaster
Sierra Online Services

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [1998-01-29 07:53 UTC] ssb
I never heard any "success reports" on SQL*Net.
Checking if he is able to connect with sqlplus.

Okay, it  turns out that he was using the wrong logon name (should
use "username@WG73").  This should be added to the documentation
for Ora_Logon.

 [2010-11-09 04:28 UTC] aharvey@php.net
Automatic comment from SVN on behalf of aharvey
Revision: http://svn.php.net/viewvc/?view=revision&revision=305216
Log: Updated example per doc bug #53269 (Fatal error in Example #6).
 [2016-02-26 16:54 UTC] willfitch@php.net
Automatic comment on behalf of wfitch@meetme.com
Revision: http://git.php.net/?p=pecl/numbers/bitset.git;a=commit;h=fbc618082cbc18af8effa2c8eaff90a327d7153b
Log: Fix #6 Add fromRawValue
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC