php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #59982 Unusable extension with --enable-mysqlnd-ms-table-filter
Submitted: 2011-10-02 11:42 UTC Modified: 2011-10-11 12:37 UTC
From: Fedora at FamilleCollet dot com Assigned: uw (profile)
Status: Closed Package: mysqlnd_ms (PECL)
PHP Version: 5.3.6 OS: GNU/Linux (Fedora 15)
Private report: No CVE-ID: None
 [2011-10-02 11:42 UTC] Fedora at FamilleCollet dot com
Description:
------------
mysqlnd_query_lexer.c doesn't include config.h, 
so MYSQLND_MS_HAVE_FILTER_TABLE_PARTITION is always undefined, 
so mysqlnd_qp_create_parser (and other functions) are not build.



Reproduce code:
---------------
./configure --build=x86_64-unknown-linux-gnu --host=x86_64-unknown-linux-gnu --program-prefix= --disable-dependency-tracking --prefix=/usr --exec-prefix=/usr --bindir=/usr/bin --sbindir=/usr/sbin --sysconfdir=/etc --datadir=/usr/share --includedir=/usr/include --libdir=/usr/lib64 --libexecdir=/usr/libexec --localstatedir=/var --sharedstatedir=/var/lib --mandir=/usr/share/man --infodir=/usr/share/info --with-libdir=lib64 --enable-mysqlnd-ms --enable-mysqlnd-ms-table-filter --with-php-config=/usr/bin/php-config

...

php -n -q -d extension_dir=modules -d extension=json.so -d extension=mysqlnd.so -d extension=mysqlnd_ms.so --modules
+ grep mysqlnd_ms


Expected result:
----------------
mysqlnd_ms

Actual result:
--------------
PHP Warning:  PHP Startup: Unable to load dynamic library 'modules/mysqlnd_ms.so' - modules/mysqlnd_ms.so: undefined symbol: mysqlnd_qp_create_parser in Unknown on line 0


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-10-02 11:46 UTC] fedora at famillecollet dot com
Simple patch which solves fix issue
https://raw.github.com/remicollet/remirepo/master/php-pecl-mysqlnd-ms/mysqlnd_ms-build.patch
 [2011-10-03 16:28 UTC] andrey@php.net
You should not build with this option turned on. This is a "dead" code, which we will stabilize in future version but decided to leave it in the code and have a configure option to enable and play with it. You are not encouraged to use it.
 [2011-10-04 15:18 UTC] ulf dot wendel at phpdoc dot de
Yes, please do not use. We will rather remove the configure flag than fix. We have been warned beforehand when adding the configure option. We went for it, although it may cause bug reports like this, because it makes our life easier. However, towards end users: DO NOT USE. Unsupported.
 [2011-10-05 00:50 UTC] fedora at famillecollet dot com
Yes, please remove the configure option, or at least, add a help message to explain this is a really experimental stuff which should no be used for now.
 [2011-10-11 12:38 UTC] uw@php.net
-Status: Feedback +Status: Closed -Assigned To: +Assigned To: uw
 [2011-10-11 12:38 UTC] uw@php.net
This bug has been fixed in SVN.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.

 For Windows:

http://windows.php.net/snapshots/
 
Thank you for the report, and for helping us make PHP better.

Removal of the option is not very practical for us. Thus, I've added "EXPERIMENTAL - do not use!" to the config.m4. Hope that will do the trick for now.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Jul 11 18:01:24 2020 UTC