php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #59973 build error: �conn_handle� has no member named �c_i5_allow_commit�
Submitted: 2011-09-28 00:55 UTC Modified: 2012-08-01 09:31 UTC
From: ushida100 at gmail dot com Assigned: rahulpriyadarshi (profile)
Status: Not a bug Package: ibm_db2 (PECL)
PHP Version: 5.3.2 OS: i5 OS V5R4
Private report: No CVE-ID: None
 [2011-09-28 00:55 UTC] ushida100 at gmail dot com
Description:
------------
I built ibm_db2 for i5OS on AIX. 
However, two declaration errors occurred by the make 
command. 

- build error 1
.../ibm_db2.c: In function '_php_db2_connect_helper':
/home/ushida5035/temp/ibm_db2-1.9.2/ibm_db2-
1.9.2/ibm_db2.c:2109: error: 'conn_handle' has no member 
named 'c_i5_allow_commit'

- build error 2
.../ibm_db2.c: In function '_ibm_db_chaining_flag':
/home/ushida5035/temp/ibm_db2-1.9.2/ibm_db2-
1.9.2/ibm_db2.c:6761: error: 'SQL_ATTR_CHAINING_BEGIN' 
undeclared (first use in this function)

I added the following two codes and solved this. 

If this information is helpful, it is glad.

Reproduce code:
---------------
build error 1 in the case
I added to "ibm_db2.c" file as follows.
114 line
 long c_i5_allow_commit;

build error 2 in the case
I added to "php_ibm_db2.h" file as follows.
line 302
 #ifdef PASE /* i5/OS ease of use turn off/on */
     #ifndef SQL_ATTR_CHAINING_BEGIN-
       #define SQL_ATTR_CHAINING_BEGIN 2464
       #define SQL_ATTR_CHAINING_END 2465
       #define SQL_IS_POINTER -4
     #endif-
 #endif /* PASE */


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-09-28 01:09 UTC] ushida100 at gmail dot com
I corrected summary
 [2012-08-01 09:31 UTC] rahulpriyadarshi@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately you are not using a current version of PHP -- 
the problem might already be fixed. Please download a new
PHP version from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.

This issue has been fixed in ibm_db2-1.9.3.
 [2012-08-01 09:31 UTC] rahulpriyadarshi@php.net
-Summary: build error: conn_handle has no member named c_i5_allow_commit +Summary: build error: �conn_handle� has no member named �c_i5_allow_commit� -Status: Open +Status: Not a bug -Assigned To: +Assigned To: rahulpriyadarshi
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun May 19 12:01:26 2019 UTC