php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #59910 Apache does not start with Ingres module
Submitted: 2011-08-24 04:12 UTC Modified: 2015-05-18 01:20 UTC
Votes:5
Avg. Score:5.0 ± 0.0
Reproduced:2 of 2 (100.0%)
Same Version:2 (100.0%)
Same OS:2 (100.0%)
From: m dot sijmons at nibble dot nl Assigned: cmb (profile)
Status: Not a bug Package: ingres (PECL)
PHP Version: 5.3.5 OS: Windows XP Prof. SP3
Private report: No CVE-ID: None
 [2011-08-24 04:12 UTC] m dot sijmons at nibble dot nl
Description:
------------
Apache will not start up and gives the following message:

OS: Windows XP Prof. SP3
PHP: 5.3.5
Apache: 2.2.17
Ingres: II 9.3.0 (int.w32/151)
Driver PHP5-5.3.2 Ingres 9.3.0-b153 
(precompiled php_ingres.dll downloaded from www.ingres.com)

Error : 
PHP Startup: ingres: Unable to initialize module
Module compiled with build ID=API20090626,TS,VC9
PHP    compiled with build ID=API20090626,TS,VC6
These options need to match

Expected result:
----------------
Succesfull startup of apache with initialized Ingres module

Actual result:
--------------
Apache starts but Ingres is not available within PHP

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2015-05-18 01:20 UTC] cmb@php.net
-Status: Open +Status: Not a bug -Assigned To: +Assigned To: cmb
 [2015-05-18 01:20 UTC] cmb@php.net
This is not a bug in PHP per se, and neither in PHP's distribution. You just have to get compatible binaries; a VC9 build of an extension is likely to be incompatible with a VC6 build of PHP.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Mon Apr 22 06:01:34 2024 UTC