php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #59905 bbcode_add_smiley priority argument
Submitted: 2011-08-19 08:31 UTC Modified: 2017-04-01 19:34 UTC
Votes:3
Avg. Score:5.0 ± 0.0
Reproduced:3 of 3 (100.0%)
Same Version:2 (66.7%)
Same OS:2 (66.7%)
From: m dot jephcote at live dot com Assigned:
Status: Wont fix Package: bbcode (PECL)
PHP Version: 5_3 SVN-2011-08-19 (dev) OS: CentOS 5.6
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2011-08-19 08:31 UTC] m dot jephcote at live dot com
Description:
------------
Is there any way to set the priority of which these are parsed? At the moment if I have an emoticon that is assigned to ":o" and another that is assigned to ":o)" the former will be parsed on the latter leaving a ")"

Would be good if there was an argument to specify the priority of parsing.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-09-26 07:41 UTC] rewt0r at gmx dot com
Has this package been abandoned?
 [2011-10-21 00:37 UTC] joaoptm78 at gmail dot com
This package is quite buggy and it does indeed appear to have been abandoned. A workaround for this bug is to order your emoticons in descending alphabetical order or starting with the longest emoticons. So for example you would first add :o) then :o via bbcode_add_smiley().
 [2017-04-01 19:34 UTC] tpunt@php.net
-Status: Open +Status: Wont fix
 [2017-04-01 19:34 UTC] tpunt@php.net
Due to this extension not seeing any activity since 2010, this issue will not be fixed. We are therefore closing this now.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Fri Nov 15 10:01:36 2019 UTC