php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #59902 Unable to store SolrQuery in a session
Submitted: 2011-08-19 05:08 UTC Modified: 2016-04-11 11:53 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:0 of 1 (0.0%)
From: bate@php.net Assigned:
Status: Not a bug Package: solr (PECL)
PHP Version: 5.3.6 OS: Debian
Private report: No CVE-ID: None
 [2011-08-19 05:08 UTC] bate@php.net
Description:
------------
its not possible to store a new SolrQuery() object in a session depends this on the Bug #17008 report because its not possible to clone an object?

Reproduce code:
---------------
$obj = new SolrQuery('Bar');
$obj->setQuery('Foo');
$_SESSION['test'] = $obj;


Expected result:
----------------
The object should be stored serialized in the session and should be restored on a next request

Actual result:
--------------
Warning: Unknown: Invalid SolrParams Index 8489. HashTable index does not exist. in Unknown on line 0 Warning: Unknown: Internal Error 1008 generated from /root/solr-1.0.1/solr_functions_helpers.c 220 solr_fetch_params_entry. The observed error is a possible side-effect of an illegal/unsupported operation in userspace. Please check the documentation and try again later. in Unknown on line 0 Warning: Unknown: Unable to serialize object in Unknown on line 0 

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2016-04-11 11:53 UTC] omars@php.net
-Status: Open +Status: Not a bug
 [2016-04-11 11:53 UTC] omars@php.net
Unable to reproduce using supported versions, it has nothing to do with cloning it.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Dec 04 08:01:23 2020 UTC