php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #59888 APC & Traits seem to cause 502s
Submitted: 2011-08-10 09:47 UTC Modified: 2012-04-13 16:24 UTC
From: Jared dot Williams1 at ntlworld dot com Assigned:
Status: Closed Package: APC (PECL)
PHP Version: Trunk SVN-2011-08-10 (dev) OS: Ubuntu 11.04
Private report: No CVE-ID: None
 [2011-08-10 09:47 UTC] Jared dot Williams1 at ntlworld dot com
Description:
------------
Opening a page containing the code below causes a 502 when 
APC is enabled.

Reproduce code:
---------------
<?php
namespace Bug
{
	interface MyInterface
	{
		function text($text);
	}

	trait MyText
	{
		function text($text)
		{
			return htmlspecialchars($text, ENT_QUOTES, 'UTF-8');
		}
	}

	class MyImplementation implements MyInterface
	{
		use MyText;
	}
}

Expected result:
----------------
No errors

Actual result:
--------------
502

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-04-13 09:38 UTC] pajoye@php.net
-Status: Open +Status: Feedback
 [2012-04-13 09:38 UTC] pajoye@php.net
Please try using 3.1.10, I can't reproduce it
 [2012-04-13 16:24 UTC] Jared dot Williams1 at ntlworld dot com
-Status: Feedback +Status: Closed
 [2012-04-13 16:24 UTC] Jared dot Williams1 at ntlworld dot com
Seems this got fixed in version 3.1.9 or before.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sat Jan 22 20:03:42 2022 UTC