php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #59829 APC should not try to canonicalize file URLs
Submitted: 2011-06-26 08:31 UTC Modified: 2012-05-01 00:09 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: damien at commerceguys dot com Assigned: rasmus
Status: Closed Package: APC (PECL)
PHP Version: 5_3 SVN-2011-06-26 (dev) OS:
Private report: No CVE-ID:
 [2011-06-26 08:31 UTC] damien at commerceguys dot com
Description:
------------
The apc.canonicalize mode (from looking at the code) seems to be specifically designed to resolve relative paths into absolute paths. More precisely, APC will not try to canonicalize absolute paths.

I would like to extend that behavior so that file URLs (in the form stream://path) are not canonicalized either. This will allow APC to work properly in stat=0,canonicalize=1 on stream-wrappers that do not implement realpath().


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-06-26 08:32 UTC] damien at commerceguys dot com
Patch for review: https://gist.github.com/950a3cd8a95e282679f0

This matches what the core PHAR extension is doing.
 [2012-05-01 00:09 UTC] rasmus@php.net
Automatic comment from SVN on behalf of rasmus
Revision: http://svn.php.net/viewvc/?view=revision&revision=325482
Log: Fix bug #59829
 [2012-05-01 00:09 UTC] rasmus@php.net
Fixed in svn
 [2012-05-01 00:09 UTC] rasmus@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: rasmus
 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Thu Apr 17 16:02:22 2014 UTC