php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #59801 geoip_db_get_all_info() segfault
Submitted: 2011-06-05 14:45 UTC Modified: 2011-06-05 15:02 UTC
From: spam2 at rhsoft dot net Assigned:
Status: Closed Package: geoip (PECL)
PHP Version: 5.3.5 OS: Linux
Private report: No CVE-ID: None
 [2011-06-05 14:45 UTC] spam2 at rhsoft dot net
Description:
------------
geoip_db_get_all_info() results in a segfault using the since two months final GeoIP 1.4.7 from http://geolite.maxmind.com/download/geoip/api/c/ which was years available for tests

1.0.7 	stable 	2009-03-11
this is quite outdated

Reproduce code:
---------------
call geoip_db_get_all_info() and php will crash

Expected result:
----------------
not crashing php


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-06-05 15:02 UTC] felipe@php.net
This bug has been fixed in SVN.

In case this was a documentation problem, the fix will show up at the
end of next Sunday (CET) on pecl.php.net.

In case this was a pecl.php.net website problem, the change will show
up on the website in short time.
 
Thank you for the report, and for helping us make PECL better.

I've fixed the crash, but the error looks like a bug in the libgeoip by missing to set a GeoIPDBFileName related to 'GeoIP CCM Edition'.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Thu Jul 09 09:01:25 2020 UTC