php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #59747 Can't install XHProf via PECL
Submitted: 2011-05-04 11:25 UTC Modified: 2011-12-06 02:30 UTC
Votes:2
Avg. Score:4.0 ± 1.0
Reproduced:2 of 2 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: pecl at yghe dot net Assigned: frozenfire (profile)
Status: Closed Package: xhprof (PECL)
PHP Version: 5.3.5 OS: Amazon Linux AMI release 2010.11
Private report: No CVE-ID: None
 [2011-05-04 11:25 UTC] pecl at yghe dot net
Description:
------------
I'm trying to document this for Phabricator but can't figure 
out how to install via pecl. I'd prefer not to give end 
users build-from-source instructions, even though the process 
isn't too difficult. Transcript in repro below.

I think my system configuration is fine; I was able to install 
it afterward by doing a github clone, cd'ing into 
"extension/", and then running "phpize && ./configure && make 
&& sudo make install". It would just be nice if a pecl 
install worked so I could provide simpler install instructions 
to users. This process also didn't add xhprof to my 
php.ini so I had to do that separately, which is another step 
to document.

Reproduce code:
---------------
$ sudo pecl install xhprof
Failed to download pecl/xhprof within preferred state "stable", latest release is version 0.9.2, stability "beta", use "channel://pecl.php.net/xhprof-0.9.2" to install
install failed

$ sudo pecl install channel://pecl.php.net/xhprof-0.9.2
downloading xhprof-0.9.2.tgz ...
Starting to download xhprof-0.9.2.tgz (931,660 bytes)
............................................done: 931,660 bytes
11 source files, building
running: phpize
Cannot find config.m4.
Make sure that you run '/usr/bin/phpize' in the top level source directory of the module

ERROR: `phpize' failed

$ pecl version
PEAR Version: 1.9.0
PHP Version: 5.3.5
Zend Engine Version: 2.3.0
Running on: Linux ip-10-170-207-10 2.6.34.7-56.40.amzn1.x86_64 #1 SMP Fri Oct 22 18:48:49 UTC 2010 x86_64


Expected result:
----------------
xhprof is installed on the system and to php.ini.

Actual result:
--------------
pecl-driven installation fails and requires build from source.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-05-04 11:26 UTC] pecl at yghe dot net
Clarifying bug title
 [2011-12-06 01:56 UTC] frozenfire@php.net
-Status: Open +Status: Bogus
 [2011-12-06 01:56 UTC] frozenfire@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

This is an issue with Amazon's EC2 service, I believe. The xhprof package 
installs just fine from the beta channel, for me. phpize seems to be failing for 
you. Beyond saying that, I don't know what else to suggest.
 [2011-12-06 02:30 UTC] frozenfire@php.net
-Status: Bogus +Status: Closed -Assigned To: +Assigned To: frozenfire
 [2011-12-06 02:30 UTC] frozenfire@php.net
Scratch that. Philip mentions that this *was* an issue, but was resolved in PEAR 
1.9.3. http://pear.php.net/package/PEAR/download/1.9.3

Thanks for the report. Should be resolved.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Mon May 27 12:01:26 2019 UTC