php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #59739 Segmentation fault when using APC_UPLOAD_PROGRESS and no file in POST
Submitted: 2011-04-28 15:28 UTC Modified: 2011-04-29 16:42 UTC
From: kbsanders at hotmail dot com Assigned:
Status: Duplicate Package: APC (PECL)
PHP Version: 5.3.6 OS: CentOS release 5.5 (Final)
Private report: No CVE-ID: None
 [2011-04-28 15:28 UTC] kbsanders at hotmail dot com
Description:
------------
Note: PHP version is actually 5.3.6, but it wasn't a choice in the dropdown.

A segmentation fault is occurring when using APC_UPLOAD_PROGRESS and no file is provided in the form POST.

No segmentation fault occurs when I remove the APC_UPLOAD_PROGRESS hidden field.

Please refer to the Post Data below.

Reproduce code:
---------------
Post Data (Note that a file field is provided, but it is blank):

Content-Type: multipart/form-data; boundary=---------------------------20600524916519 Content-Length: 1067 -----------------------------20600524916519 Content-Disposition: form-data; name="fileFolderId" A1C8C933933919359DB0048F3E976D90 -----------------------------20600524916519 Content-Disposition: form-data; name="fileContextId" B1C8C933933919359DB0048F3E976DC7 -----------------------------20600524916519 Content-Disposition: form-data; name="groupId" CC4917A4C2EE52BD414917A4219C0B3E -----------------------------20600524916519 Content-Disposition: form-data; name="name" File Title -----------------------------20600524916519 Content-Disposition: form-data; name="copyright" File Copyright -----------------------------20600524916519 Content-Disposition: form-data; name="APC_UPLOAD_PROGRESS" C4C0364EB09000016AD2130DBDD3C160 -----------------------------20600524916519 Content-Disposition: form-data; name="description" File Description -----------------------------20600524916519 Content-Disposition: form-data; name="file"; filename="" Content-Type: application/octet-stream -----------------------------20600524916519--

Expected result:
----------------
No segmentation fault. Gracefully ignore blank file field.

Actual result:
--------------
Apache Error Log:

[Thu Apr 28 14:32:45 2011] [notice] child pid 25128 exit signal Segmentation fault (11)

Web Browser:

Blank response and blank response headers.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-04-29 08:45 UTC] gopalv@php.net
If I'm not wrong, this is a duplicate of 

http://pecl.php.net/bugs/bug.php?id=20016

Please test svn again & report back.
 [2011-04-29 16:42 UTC] kbsanders at hotmail dot com
Compiled latest from SVN (v3.1.8 $Revision: 308812 $)
Everything seems to be working OK now.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Aug 03 08:01:25 2021 UTC