php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #59738 Package doesn't compile
Submitted: 2011-04-28 10:02 UTC Modified: 2016-12-28 14:41 UTC
From: franck at cassedanne dot com Assigned: cmb (profile)
Status: Duplicate Package: SCA_SDO (PECL)
PHP Version: 5.3.0 OS: Darwin 10.7.0
Private report: No CVE-ID: None
 [2011-04-28 10:02 UTC] franck at cassedanne dot com
Description:
------------
Does not compile against PHP 5.3.X on OS X 10.6.7

Reproduce code:
---------------
pecl install SCA_SDO

Actual result:
--------------
downloading SCA_SDO-1.2.4.tgz ...
Starting to download SCA_SDO-1.2.4.tgz (576,531 bytes)
............................................................
........................................................done
: 576,531 bytes
194 source files, building
running: phpize
Configuring for:
PHP Api Version:         20090626
Zend Module Api No:      20090626
Zend Extension Api No:   220090626
configure.in:3: warning: prefer named diversions
configure.in:3: warning: prefer named diversions
building in /var/tmp/pear-build-franck/SCA_SDO-1.2.4
running: /tmp/pear/download/SCA_SDO-1.2.4/configure
checking for grep that handles long lines and -e... 
/usr/bin/grep
checking for egrep... /usr/bin/grep -E
checking for a sed that does not truncate output... 
/opt/local/bin/gsed
checking for cc... cc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables...
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether cc accepts -g... yes
checking for cc option to accept ISO C89... none needed
checking how to run the C preprocessor... cc -E
checking for icc... no
checking for suncc... no
checking whether cc understands -c and -o together... yes
checking for system library directory... lib
checking if compiler supports -R... no
checking if compiler supports -Wl,-rpath,... yes
checking build system type... i386-apple-darwin10.7.0
checking host system type... i386-apple-darwin10.7.0
checking target system type... i386-apple-darwin10.7.0
checking for PHP prefix... /opt/local
checking for PHP includes... -I/opt/local/include/php -
I/opt/local/include/php/main -I/opt/local/include/php/TSRM -
I/opt/local/include/php/Zend -I/opt/local/include/php/ext -
I/opt/local/include/php/ext/date/lib -I/opt/local/include
checking for PHP extension directory... 
/opt/local/lib/php/extensions/no-debug-non-zts-20090626
checking for PHP installed headers prefix... 
/opt/local/include/php
checking if debug is enabled... no
checking if zts is enabled... no
checking for re2c... re2c
checking for re2c version... 0.13.5 (ok)
checking for gawk... gawk
checking whether to enable SDO support... yes, shared
checking libxml2 install dir... no
checking for xml2-config path... /usr/bin/xml2-config
checking whether libxml build works... yes
checking for swprintf... yes
checking for g++... g++
checking whether we are using the GNU C++ compiler... yes
checking whether g++ accepts -g... yes
checking how to run the C++ preprocessor... g++ -E
checking for ld used by cc... /usr/libexec/gcc/i686-apple-
darwin10/4.2.1/ld
checking if the linker (/usr/libexec/gcc/i686-apple-
darwin10/4.2.1/ld) is GNU ld... no
checking for /usr/libexec/gcc/i686-apple-darwin10/4.2.1/ld 
option to reload object files... -r
checking for BSD-compatible nm... /usr/bin/nm
checking whether ln -s works... yes
checking how to recognize dependent libraries... pass_all
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking dlfcn.h usability... yes
checking dlfcn.h presence... yes
checking for dlfcn.h... yes
checking how to run the C++ preprocessor... g++ -E
checking the maximum length of command line arguments... 
196608
checking command to parse /usr/bin/nm output from cc 
object... ok
checking for objdir... .libs
checking for ar... ar
checking for ranlib... ranlib
checking for strip... strip
checking for dsymutil... dsymutil
checking for nmedit... nmedit
checking for -single_module linker flag... yes
checking for -exported_symbols_list linker flag... yes
checking if cc supports -fno-rtti -fno-exceptions... no
checking for cc option to produce PIC... -fno-common
checking if cc PIC flag -fno-common works... yes
checking if cc static flag -static works... no
checking if cc supports -c -o file.o... yes
checking whether the cc linker (/usr/libexec/gcc/i686-apple-
darwin10/4.2.1/ld) supports shared libraries... yes
checking dynamic linker characteristics... darwin10.7.0 dyld
checking how to hardcode library paths into programs... 
immediate
checking whether stripping libraries is possible... yes
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... no

creating libtool
appending configuration tag "CXX" to libtool
checking for ld used by g++... /usr/libexec/gcc/i686-apple-
darwin10/4.2.1/ld
checking if the linker (/usr/libexec/gcc/i686-apple-
darwin10/4.2.1/ld) is GNU ld... no
checking whether the g++ linker (/usr/libexec/gcc/i686-
apple-darwin10/4.2.1/ld) supports shared libraries... yes
checking for g++ option to produce PIC... -fno-common
checking if g++ PIC flag -fno-common works... yes
checking if g++ static flag -static works... no
checking if g++ supports -c -o file.o... yes
checking whether the g++ linker (/usr/libexec/gcc/i686-
apple-darwin10/4.2.1/ld) supports shared libraries... yes
checking dynamic linker characteristics... darwin10.7.0 dyld
(cached) (cached) checking how to hardcode library paths 
into programs... immediate
configure: creating ./config.status
config.status: creating config.h
running: make
/bin/sh /private/var/tmp/pear-build-franck/SCA_SDO-
1.2.4/libtool --mode=compile g++ -
I/tmp/pear/download/SCA_SDO-1.2.4 -I. -
I/tmp/pear/download/SCA_SDO-1.2.4 -DPHP_ATOM_INC -
I/private/var/tmp/pear-build-franck/SCA_SDO-1.2.4/include -
I/private/var/tmp/pear-build-franck/SCA_SDO-1.2.4/main -
I/tmp/pear/download/SCA_SDO-1.2.4 -I/opt/local/include/php -
I/opt/local/include/php/main -I/opt/local/include/php/TSRM -
I/opt/local/include/php/Zend -I/opt/local/include/php/ext -
I/opt/local/include/php/ext/date/lib -I/opt/local/include -
I/usr/include/libxml2  -DHAVE_CONFIG_H  -g -O2   -c 
/tmp/pear/download/SCA_SDO-1.2.4/sdo.cpp -o sdo.lo
mkdir .libs
 g++ -I/tmp/pear/download/SCA_SDO-1.2.4 -I. -
I/tmp/pear/download/SCA_SDO-1.2.4 -DPHP_ATOM_INC -
I/private/var/tmp/pear-build-franck/SCA_SDO-1.2.4/include -
I/private/var/tmp/pear-build-franck/SCA_SDO-1.2.4/main -
I/tmp/pear/download/SCA_SDO-1.2.4 -I/opt/local/include/php -
I/opt/local/include/php/main -I/opt/local/include/php/TSRM -
I/opt/local/include/php/Zend -I/opt/local/include/php/ext -
I/opt/local/include/php/ext/date/lib -I/opt/local/include -
I/usr/include/libxml2 -DHAVE_CONFIG_H -g -O2 -c 
/tmp/pear/download/SCA_SDO-1.2.4/sdo.cpp  -fno-common -DPIC 
-o .libs/sdo.o
/tmp/pear/download/SCA_SDO-1.2.4/sdo.cpp:80: error: 
conflicting specifiers in declaration of 
'arginfo_sdo_dataobject'
/tmp/pear/download/SCA_SDO-1.2.4/sdo.cpp:86: error: 
conflicting specifiers in declaration of 'arginfo___get'
/tmp/pear/download/SCA_SDO-1.2.4/sdo.cpp:90: error: 
conflicting specifiers in declaration of 'arginfo___set'
/tmp/pear/download/SCA_SDO-1.2.4/sdo.cpp:103: error: 
conflicting specifiers in declaration of 
'arginfo_sdo_dataobject_createdataobject'
/tmp/pear/download/SCA_SDO-1.2.4/sdo.cpp:119: error: 
conflicting specifiers in declaration of 
'arginfo_sdo_sequence_getproperty'
/tmp/pear/download/SCA_SDO-1.2.4/sdo.cpp:123: error: 
conflicting specifiers in declaration of 
'arginfo_sdo_sequence_move'
/tmp/pear/download/SCA_SDO-1.2.4/sdo.cpp:128: error: 
conflicting specifiers in declaration of 
'arginfo_sdo_sequence_insert'
/tmp/pear/download/SCA_SDO-1.2.4/sdo.cpp:144: error: 
conflicting specifiers in declaration of 
'arginfo_sdo_list_insert'
/tmp/pear/download/SCA_SDO-1.2.4/sdo.cpp:158: error: 
conflicting specifiers in declaration of 
'arginfo_sdo_datafactory_create'
/tmp/pear/download/SCA_SDO-1.2.4/sdo.cpp:177: error: 
conflicting specifiers in declaration of 
'arginfo_sdo_das_datafactory_addType'
/tmp/pear/download/SCA_SDO-1.2.4/sdo.cpp:183: error: 
conflicting specifiers in declaration of 
'arginfo_sdo_das_datafactory_addPropertyToType'
/tmp/pear/download/SCA_SDO-1.2.4/sdo.cpp:263: error: 
conflicting specifiers in declaration of 
'arginfo_sdo_model_type_identifier'
/tmp/pear/download/SCA_SDO-1.2.4/sdo.cpp:325: error: 
conflicting specifiers in declaration of 
'arginfo_sdo_model_reflectiondataobject_export'
/tmp/pear/download/SCA_SDO-1.2.4/sdo.cpp:411: warning: 
deprecated conversion from string constant to 'char*'
/tmp/pear/download/SCA_SDO-1.2.4/sdo.cpp: In function 'int 
zm_startup_sdo(int, int)':
/tmp/pear/download/SCA_SDO-1.2.4/sdo.cpp:447: warning: 
deprecated conversion from string constant to 'char*'
make: *** [sdo.lo] Error 1
ERROR: `make' failed


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-04-28 10:10 UTC] franck at cassedanne dot com
Same apply to PHP 5.3.5 on FreeBSD 8.1 which seems to suggest 
this extension does not compile at all from PHP 5.3 onward.
 [2011-06-09 05:51 UTC] oliver at openbrackets dot net
yeah..no luck here either

this guy seemed to make some progress

http://www.mail-archive.com/phpsoa@googlegroups.com/msg00813.html

have emailed him to check if it worked
 [2016-12-28 14:41 UTC] cmb@php.net
-Summary: Darwin dev 10.7.0 Darwin Kernel Version 10.7.0: Sat Jan 29 15:17:16 PST 2011; r +Summary: Package doesn't compile -Status: Open +Status: Duplicate -Assigned To: +Assigned To: cmb
 [2016-12-28 14:41 UTC] cmb@php.net
Duplicate of bug #58951.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Thu Jun 04 11:01:24 2020 UTC