php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #59722 executable php from prompt triggers warning
Submitted: 2011-04-19 06:14 UTC Modified: 2016-08-31 16:04 UTC
Votes:3
Avg. Score:4.7 ± 0.5
Reproduced:3 of 3 (100.0%)
Same Version:1 (33.3%)
Same OS:1 (33.3%)
From: stakadush at yahoo dot com Assigned: cmb (profile)
Status: Wont fix Package: APC (PECL)
PHP Version: 5.3.5 OS: ubuntu & rhel5
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2011-04-19 06:14 UTC] stakadush at yahoo dot com
Description:
------------
try to execute a php script as an executable causes apc to 
return an error. executing php directly works fine.


this causes an error:
./test.php


this works fine:
/usr/bin/php test.php

Reproduce code:
---------------
create a php script, test.php

put inside:

#!/usr/bin/env php
<?php
echo "ok\n";
?>


then

chmod +x test.php

then try:

./test.php



Expected result:
----------------
no warning

Actual result:
--------------
got a warning:

Warning: Unknown: apc failed to locate ./test.php - bailing in 
Unknown on line 0

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-10-04 05:57 UTC] david at myself-design dot com
same here with PHP 5.3.6-6~dotdeb.0
 [2012-03-22 12:30 UTC] php dot net at doppy dot nl
I'm not able to reproduce this. It works perfectly for me.

Is APC working normally when via Apache?


PHP 5.3.5-1ubuntu7.7 with Suhosin-Patch (cli) (built: Feb 11 2012 06:22:51) 
Copyright (c) 1997-2009 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2010 Zend Technologies
 [2016-08-31 16:04 UTC] cmb@php.net
-Status: Open +Status: Wont fix -Assigned To: +Assigned To: cmb
 [2016-08-31 16:04 UTC] cmb@php.net
According to <https://bugs.php.net/69618>, APC support has been
discontinued in favor of OPcache, APCu, the session upload
progress API and WinCache. Therefore this issue won't get fixed.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Wed Feb 28 13:01:27 2024 UTC