php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #59704 getResponse() ruturns Fatal Error "Error un-serializing response"
Submitted: 2011-04-08 02:24 UTC Modified: 2011-06-04 04:23 UTC
From: haspadar at gmail dot com Assigned:
Status: Closed Package: solr (PECL)
PHP Version: 5.3.3 OS: Ubuntu 10.10 x64
Private report: No CVE-ID: None
 [2011-04-08 02:24 UTC] haspadar at gmail dot com
Description:
------------
For Solr 3.1 version methos getResponse() returns the Fatal error: "Uncaught exception 'SolrException' with message 'Error un-serializing response' in /home/user/project/mySolr.php:77"

Reproduce code:
---------------
$solrQuery = new SolrQuery();
$solrQuery->setQuery($query);
$config = array('host' => '127.0.0.1', 'port' => 8983);
$solrClient = new SolrClient($config);
$solrObject = $solrClient->query($solrQuery)->getResponse();


Expected result:
----------------
The correct SolrObject data

Actual result:
--------------
Fatal error: "Uncaught exception 'SolrException' with message 'Error un-serializing response' in /home/user/project/mySolr.php:77

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-06-04 04:23 UTC] iekpo@php.net
Sorry, but your problem does not imply a bug in PECL itself.  For a
list of more appropriate places to ask for help using PECL, please
visit http://pecl.php.net/support.php as this bug system is not the
appropriate forum for asking support questions. 

Thank you for your interest in PECL.

This is due to control characters in the solr response.

Try using the JSON response writer in the SolrClient constructor which is available in 1.0.1
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Wed Dec 08 02:03:34 2021 UTC