php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #59682 memcached.so: undefined symbol: igbinary_unserialize in Unknown on line 0
Submitted: 2011-03-23 13:59 UTC Modified: 2012-03-07 05:48 UTC
Votes:2
Avg. Score:4.5 ± 0.5
Reproduced:2 of 2 (100.0%)
Same Version:0 (0.0%)
Same OS:1 (50.0%)
From: steve dot fortin at cogecodiffusion dot com Assigned:
Status: Wont fix Package: memcached (PECL)
PHP Version: 5.2.14 OS: RedHat
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2011-03-23 13:59 UTC] steve dot fortin at cogecodiffusion dot com
Description:
------------
Hi,

I only have 1 more issue when I install, when i try to link memcached with igbinary

that is how i installed igbinary:

::igbinary::
pecl download igbinary
gzip -d < igbinary-1.1.1.tgz | tar -xvf -
cd igbinary-1.1.1
phpize
./configure --libdir=/usr/lib64/ --libexecdir=/usr/lib64/
make
make install


::memcached-1.4.5::
cd /usr/local/src; curl -O http://memcached.googlecode.com/files/memcached-1.4.5.tar.gz
tar zxvf memcached-1.4.5.tar.gz
cd memcached-1.4.5
./configure --libdir=/usr/lib64/ --libexecdir=/usr/lib64/ 
make
make install


::libmemcached-0.48::
cd /usr/local/src; wget http://launchpad.net/libmemcached/1.0/0.48/+download/libmemcached-0.48.tar.gz
tar zxvf libmemcached-0.48.tar.gz
cd libmemcached-0.48
./configure --libdir=/usr/lib64 --libexecdir=/usr/lib64; make
make install


::memcached-2.0.0b1::
phpize
./configure --libdir=/usr/lib64 --libexecdir=/usr/lib64 --enable-memcached=shared --enable-memcached-igbinary
make
make install
make test

----------------------------------------------------------------------

Build complete.
Don't forget to run 'make test'.

PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/local/src/memcached-2.0.0b1/modules/memcached.so' - /usr/local/src/memcached-2.0.0b1/modules/memcached.so: undefined symbol: igbinary_unserialize in Unknown on line 0

Warning: PHP Startup: Unable to load dynamic library '/usr/local/src/memcached-2.0.0b1/modules/memcached.so' - /usr/local/src/memcached-2.0.0b1/modules/memcached.so: undefined symbol: igbinary_unserialize in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/local/src/memcached-2.0.0b1/modules/memcached.so' - /usr/local/src/memcached-2.0.0b1/modules/memcached.so: undefined symbol: igbinary_unserialize in Unknown on line 0

Warning: PHP Startup: Unable to load dynamic library '/usr/local/src/memcached-2.0.0b1/modules/memcached.so' - /usr/local/src/memcached-2.0.0b1/modules/memcached.so: undefined symbol: igbinary_unserialize in Unknown on line 0

=====================================================================
PHP         : /usr/bin/php
PHP_SAPI    : cli
PHP_VERSION : 5.2.14
ZEND_VERSION: 2.2.0
PHP_OS      : Linux - Linux 2134011.pubip.peer1.net 2.6.18-238.1.1.el5 #1 SMP Tue Jan 4 13:32:19 EST 2011 x86_64
INI actual  : /usr/local/src/memcached-2.0.0b1/tmp-php.ini
More .INIs  :
CWD         : /usr/local/src/memcached-2.0.0b1
Extra dirs  :
VALGRIND    : Not used
=====================================================================
TIME START 2011-03-23 18:35:58
=====================================================================
No tests were run.


when I do a phpinfo();
I see my igbinary working
igbinary

igbinary support  enabled  
igbinary version  1.1.1  
igbinary APC serializer ABI  0  

Directive Local Value Master Value 
igbinary.compact_strings On On 


if that can help

ldd /usr/local/src/memcached-2.0.0b1/modules/memcached.so
        linux-vdso.so.1 =>  (0x00007fff9edfc000)
        libmemcached.so.6 => /usr/lib64/libmemcached.so.6 (0x00002b88f27d6000)
        libz.so.1 => /usr/lib64/libz.so.1 (0x00002b88f29ec000)
        libc.so.6 => /lib64/libc.so.6 (0x00002b88f2c01000)
        libsasl2.so.2 => /usr/lib64/libsasl2.so.2 (0x00002b88f2f59000)
        libm.so.6 => /lib64/libm.so.6 (0x00002b88f3172000)
        librt.so.1 => /lib64/librt.so.1 (0x00002b88f33f6000)
        libpthread.so.0 => /lib64/libpthread.so.0 (0x00002b88f35ff000)
        /lib64/ld-linux-x86-64.so.2 (0x00000036c9800000)
        libdl.so.2 => /lib64/libdl.so.2 (0x00002b88f381a000)
        libresolv.so.2 => /lib64/libresolv.so.2 (0x00002b88f3a1f000)
        libcrypt.so.1 => /lib64/libcrypt.so.1 (0x00002b88f3c34000)



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-03-23 14:24 UTC] steve dot fortin at cogecodiffusion dot com
well the test failed but it is working into php

phpinfo();

memcached
memcached support enabled 
Version  2.0.0b1  
libmemcached version  0.48  
Session support  yes  
igbinary support  yes  
json support  no  

Directive Local Value Master Value 
memcached.compression_factor 1.3 1.3 
memcached.compression_threshold 2000 2000 
memcached.compression_type fastlz fastlz 
memcached.serializer igbinary igbinary 
memcached.sess_lock_wait 150000 150000 
memcached.sess_locking 1 1 
memcached.sess_prefix memc.sess.key. memc.sess.key. 
memcached.use_sasl 0 0
 [2011-07-18 09:34 UTC] pecl_bugs at zerocue dot com
Did you ever find a solution to this?  

Looks like a few spammers are also running into this. :P
 [2011-07-18 09:48 UTC] pecl_bugs at zerocue dot com
The fix for this is to ensure igbinary is loaded before memcached.so
 [2012-03-07 05:48 UTC] andrei@php.net
-Status: Open +Status: Wont fix
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Jul 11 18:01:24 2020 UTC