php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #59528 MemcachePool::getextendedstats() failed with: CLIENT_ERROR bad command line
Submitted: 2010-12-03 18:50 UTC Modified: 2010-12-05 10:25 UTC
Votes:2
Avg. Score:3.5 ± 0.5
Reproduced:2 of 2 (100.0%)
Same Version:1 (50.0%)
Same OS:1 (50.0%)
From: kaplich at gmail dot com Assigned: hradtke (profile)
Status: Wont fix Package: memcache (PECL)
PHP Version: 5_3 SVN-2010-12-03 (dev) OS: Cent OS 5.5
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2010-12-03 18:50 UTC] kaplich at gmail dot com
Description:
------------
MemcachePool::getextendedstats() causes PHP notice

PHP 5.3.3
memcache 3.0.5
memcached 1.4.5
Cent OS 5.5

Reproduce code:
---------------
<?php

$memcache = new Memcache;
$memcache->connect('127.0.0.1', 11211);
$memcache->set('test_key1', '1', 0, 5);
$memcache->set('test_key2', '1', 0, 5);

foreach ($memcache->getExtendedStats('slabs') as $server => $slabs)
    foreach (array_keys($slabs) as $slabId) 
        $memcache->getExtendedStats('cachedump', (int) $slabId);


Expected result:
----------------
scripts runs without any notices

Actual result:
--------------
PHP Notice:  MemcachePool::getextendedstats(): Server 127.0.0.1 (tcp 11211, udp 0) failed with: CLIENT_ERROR bad command line
 (0) in /projects/mongodb_odm/lib/vendor/doctrine-common/tests/Doctrine/Tests/Common/Cache/memcache_bug.php on line 9


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-12-05 10:25 UTC] hradtke@php.net
This is expected.  The cachedump stat type was never part of the protocol.  It was removed due to security concerns.  I updated the documentation to reflect this.
 [2011-01-06 20:08 UTC] alexartwww at yandex dot ru
how to get 'cachedump' back?
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Mar 28 20:01:23 2020 UTC