php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #59487 Memory leaks on upgrading from 3.0.19 to 3.1.4
Submitted: 2010-10-30 04:03 UTC Modified: 2010-12-06 13:57 UTC
From: webmaster_apc at colnect dot com Assigned:
Status: Closed Package: APC (PECL)
PHP Version: 5.3.2 OS: gentoo linux
Private report: No CVE-ID: None
 [2010-10-30 04:03 UTC] webmaster_apc at colnect dot com
Description:
------------
Running a Gentoo Linux machine and tried twice to upgrade from 3.0.19 to 3.1.4 with both current PHP 5.3.3-pl1-gentoo and a previous version of PHP.

On both times APC appears to run well except for the fact that it leaks memory until its memory fills up. Checking the keys on APC, it seems that keys that were supposed to be deleted and/or expired simply stay in the cache.

In addition (and perhaps unrelated), the report generated by apc.php looks weird, it seems the pie chart is drawn twice. I can attach a picture.

Reproduce code:
---------------
Sorry, cannot provide code.

Expected result:
----------------
Smooth operation as in APC 3.0.19

Mind no code changes were made and downgrading back to 3.0.19 resolves the issues


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-11-03 19:21 UTC] pierre dot php at gmail dot com
Please try using 3.1.5
 [2010-11-04 02:14 UTC] webmaster_apcx at colnect dot com
Use the following PHP script to re-create the issue.
It given inconsistent results on deleting keys using 3.1.4 (run it a few times and you'll see) and is very consistent on 3.0.19

:


<?php

function yesno($val) {
	if ($val) echo '<br/>Yes<br/>';
	else echo '<br/>NO<br/>';
}

$key = 'loloo';
echo 'Key is '. $key. '<br/>';
yesno(apc_store($key, 'dataaaaaa', 999));
yesno(apc_delete($key));
yesno(apc_store($key, 'dataaaaaa', 999));
yesno(apc_delete($key));

die('<br/>done'. date('c'));
 [2010-11-04 03:30 UTC] pierre dot php at gmail dot com
Please try using APC 3.1.5 (latest release), not 3.1.4.
 [2010-12-06 13:57 UTC] webmaster_apc at colnect dot com
Confirmed: fixed in 3.1.5
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sat Jun 19 17:01:23 2021 UTC