php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #59463 SCA_SDO win compilation problem.
Submitted: 2010-10-14 07:17 UTC Modified: 2010-10-14 07:55 UTC
From: s111s999 at hotmail dot com Assigned:
Status: Not a bug Package: SCA_SDO (PECL)
PHP Version: 5.3.1 OS: Windows 7
Private report: No CVE-ID: None
 [2010-10-14 07:17 UTC] s111s999 at hotmail dot com
Description:
------------
c:\xampp\php>pecl install SCA_SDO
downloading SCA_SDO-1.2.4.tgz ...
Starting to download SCA_SDO-1.2.4.tgz (576,531 bytes)
........................done: 576,531 bytes
194 source files, building
WARNING: php_bin \xampp\php\php.exe appears to have a suffix \php.exe,
but config variable php_suffix does not match
ERROR: The DSP SCA_SDO.dsp does not exist.

What is this .DSP file, what is it used for?


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-10-14 07:55 UTC] cem@php.net
Thank you for taking the time to write to us, but this is not
a bug.

If you read the INSTALL file in the package (also at http://svn.php.net/viewvc/pecl/sdo/trunk/INSTALL?view=markup), you'll see that it does say that this method will only work for *IX operating systems. It tells you to use 

pecl install -B SCA_SDO

Now for the bad news - this assumes you have a pre-built Windows DLL available to install. However the site which used to build these automatically (http://pecl4win.php.net/) has been out of action for rather a long while now, and shows little promise of resuming its duties. Meanwhile, the old pre-built extensions which used to be there have been removed by the people who run that site.

If you are into building php extensions on Windows, then you can build the dll yourself. If you don't want to do that, then probably the way to get hold of an SDO extension for Windows would be to appeal for it on the SCA_SDO mailing list: http://groups.google.com/group/phpsoa. 

Sorry this is so unsatisfactory.
 [2012-04-19 23:41 UTC] brent dot newland at casipc dot com
The root cause of this problem is discussed here: http://pear.php.net/bugs/bug.php?id=17016
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Mon Nov 18 21:01:37 2019 UTC