php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #59437 FreeBSD: gmagick causes "bad system call" error
Submitted: 2010-09-24 13:28 UTC Modified: 2012-07-31 05:31 UTC
From: hd at onlinecity dot dk Assigned: vito
Status: Closed Package: gmagick (PECL)
PHP Version: 5.3.3 OS: FreeBSD 7.2-STABLE
Private report: No CVE-ID:
 [2010-09-24 13:28 UTC] hd at onlinecity dot dk
Description:
------------
Running on PHP 5.3.3 on FreeBSD 7.2 (64 bit).

I tried with both gmagick 1.0.8, 1.0.7 and 1.0.3.

Using GraphicsMagick 1.3.12 from FreeBSD ports.

Reproduce code:
---------------
1) Install GraphicsMagick 1.3.12 from FreeBSD ports. (http://www.freshports.org/graphics/GraphicsMagick13/)
2) Download lastest GMagick from PECL.
3) ./phpize
4) ./configure
5) ./make
6) ./make test


Expected result:
----------------
No errors

Actual result:
--------------
Bad system call (core dumped)

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-09-24 13:32 UTC] hd at onlinecity dot dk
# /usr/local/bin/gm version
GraphicsMagick 1.3.12 2010-03-08 Q8 http://www.GraphicsMagick.org/
Host type: amd64-portbld-freebsd7.2

Configured using the command:
  ./configure  '--without-perl' '--enable-shared' '--enable-static' '--with-ltdl-include=/usr/local/include' '--with-ltdl-lib=/usr/local/lib' '--with-fpx' '--with-dps' '--with-threads' '--enable-openmp' '--disable-openmp-slow' '--with-quantum-depth=8' '--prefix=/usr/local' '--mandir=/usr/local/man' '--infodir=/usr/local/info/' '--build=amd64-portbld-freebsd7.2' 'build_alias=amd64-portbld-freebsd7.2' 'CC=cc' 'CFLAGS=-O2 -fno-strict-aliasing -pipe' 'LDFLAGS=-L/usr/local/lib -pthread' 'CPPFLAGS=-I/usr/local/include' 'CXX=c++' 'CXXFLAGS=-O2 -fno-strict-aliasing -pipe'

# php -v
PHP 5.3.3 with Suhosin-Patch (cli) (built: Sep 21 2010 01:25:49)
 [2012-02-14 19:55 UTC] phpdebug at mailinator dot com
caused by dlopen-ing a library with OpenMP by a non-OpenMP process 
http://freebsd.1045724.n5.nabble.com/dlopen-ing-a-library-with-OpenMP-by-a-non-OpenMP-process-td3964632.html

solution:
configure GraphicsMagick with --disable-openmp before building gmagick extension
 [2012-07-31 05:18 UTC] vito@php.net
-Status: Assigned +Status: Open -Assigned To: vitoc +Assigned To:
 [2012-07-31 05:31 UTC] vito@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: vito
 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Fri Apr 18 20:01:57 2014 UTC