php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #59428 Segmentation error on installation of Zip package
Submitted: 2010-09-17 09:08 UTC Modified: 2013-10-23 07:59 UTC
From: quentin dot albrand at gmail dot com Assigned:
Status: Not a bug Package: zip (PECL)
PHP Version: 5.3.2 OS: Ubuntu 10.04 server
Private report: No CVE-ID: None
 [2010-09-17 09:08 UTC] quentin dot albrand at gmail dot com
Description:
------------
I'm trying to install the zip package from PECL, I installed 
first php5-dev and make but when I try to launch the 
installation this is what I get.




Reproduce code:
---------------
buzenval@ubuntu-web-server:~$ sudo pecl install zip


Expected result:
----------------
Installation of PECL zip package

Actual result:
--------------
buzenval@ubuntu-web-server:~$ sudo pecl install zip
downloading zip-1.10.2.tgz ...
Starting to download zip-1.10.2.tgz (236,912 bytes)
........................done: 236,912 bytes
61 source files, building
running: phpize
Configuring for:
PHP Api Version:         20090626
Zend Module Api No:      20090626
Zend Extension Api No:   220090626
building in /var/tmp/pear-build-root/zip-1.10.2
running: /tmp/pear/temp/zip/configure
Segmentation fault

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-09-17 13:52 UTC] spektom at gmail dot com
Moving to Zip extension.
 [2013-10-23 07:59 UTC] remi@php.net
-Status: Open +Status: Not a bug
 [2013-10-23 07:59 UTC] remi@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately you are not using a current version of PHP -- 
the problem might already be fixed. Please download a new
PHP version from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.

Zip extension is now included in php sources.

Pecl version 1.12.2 build with php >= 5.3
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Apr 03 21:01:23 2020 UTC