php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #59419 empty includes array
Submitted: 2010-09-14 08:50 UTC Modified: 2012-06-12 16:48 UTC
From: fgm at osinet dot fr Assigned:
Status: Not a bug Package: inclued (PECL)
PHP Version: 5.3.2-1ubuntu4.2 OS: Ubuntu Lucid
Private report: No CVE-ID: None
 [2010-09-14 08:50 UTC] fgm at osinet dot fr
Description:
------------
Create two files as below. Configure inclued, invoke.

Reproduce code:
---------------
<?php
// in file a.php
require_once('b.php');
?>

<?
// in file b.php
echo 'foo';
?>


Expected result:
----------------
Expected result: 

- display "foo"
- /tmp/inclued.(nnnnn).(pp) created
- /tmp/inclued.(nnnnn).(pp) contains a one-item array under the key "includes".

Actual result:
--------------
The "includes" array is empty. As here:

a:4:{s:7:"request";a:5:{s:8:"_REQUEST";a:0:{}s:7:"_COOKIE";a:0:{}s:15:"SCRIPT_FILENAME";s:20:"/home/www-data/a.php";s:11:"REQUEST_URI";s:6:"/a.php";s:12:"REQUEST_TIME";i:1284468345;}s:8:"includes";a:0:{}s:11:"inheritance";a:0:{}s:7:"classes";a:0:{}}

On larger examples (drupal), the inheritance array fills nicely, but the includes array remains empty.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-09-14 09:02 UTC] fgm at osinet dot fr
Q
 [2010-09-14 09:04 UTC] fgm at osinet dot fr
But the same test works normally on Ubuntu Karmic with PHP 5.2.10-2ubuntu6.4.
 [2011-03-22 07:10 UTC] quinton+pecl at take2 dot co dot za
i am experiencing the same issue/problem using php 5.3.2-
1ubuntu4 ie. ubuntu lucid 10.04.1 lts server
 [2011-04-11 19:27 UTC] dharkness at gmail dot com
I have the same problem with PHP 5.3.3-1ubuntu9.3 on Ubuntu 
10.10. The includes array remains empty while the other 
arrays are filled.
 [2011-11-21 05:55 UTC] hjkim at mkinternet dot com
If you use php with debug like Xdebug, turn it off.

I had a same issue with CentOS5 + PHP 5.3.3(5.3.8) + Xdebug.
But, when I added a semicolon(;) at 'zend_extension=xdebug.so', 
it works nicely.

Try it.
 [2012-06-12 16:48 UTC] felipe@php.net
-Status: Open +Status: Not a bug
 [2012-06-12 16:48 UTC] felipe@php.net
Try disabling xdebug.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Tue Oct 15 03:01:28 2019 UTC