php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #5940 max_execution_time ever allow 30sec which could be insuffisent in dns lookup
Submitted: 2000-08-03 11:16 UTC Modified: 2000-08-03 15:23 UTC
From: brunofr at ioda dot net Assigned:
Status: Closed Package: Scripting Engine problem
PHP Version: 4.0.1pl2 OS: WinnT 4.0 SP6a French
Private report: No CVE-ID: None
 [2000-08-03 11:16 UTC] brunofr at ioda dot net
Ok with the engine I use the php.ini-optimized,
I use php for DNS lookup in one script.
even I modify the max_execution_time in php.ini, php stop execution with the
message : "Maximum execution time of 30 seconds exceeded in line 155.
the line is 
$name=gethostbyaddr($ip_add);

This script was in use from January with all different version of php4.0
(beta to the lastest release ).

If I replaced with php4.01pl2 with php4.0 it work fine

i used ZendOptimizer too with level 15.

A quick fix could help me ......
Thanks 
Bruno Friedmann
Internet Manager

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-08-03 11:20 UTC] stas@php.net
If you need more execution time, change the max_execution_time parameter. Check that you are reading right php.ini.
 [2000-08-03 11:43 UTC] brunofr at ioda dot net
If I say there's a bug it's because I try to change the parameter in the ini.
Put it to 600 or 3600 there's no difference.

be careful, because there's a comment on beta and RC behind the line saying ;Unix only....

TEST and read before answering anything WRONG please ....

ReOpen the bug ... It's not closed so simply.
I'm not a script kiddie calling his mother.

Regards.
Bruno
 [2000-08-03 13:18 UTC] brunofr at ioda dot net
Ok some important precisions.

The max_execution_time is really load with php on web mode, when i change it on php.ini i can see the difference on phpinfo().

But the problem still remain.

I launch my script manually on command line, in a Windows NT cmd box. 
the command is like
d:\test\php -q -f dnsreplace.php 08 2000
php is on my path ( before winnt and other ). in d:/php/ all file inside 
nothing in c:\winnt

AND I'VE Found, every thing work fine if web mode with all file in the php directory. but in cmd mode
YOU MUST HAVE php.ini in the WINDAUBE directory ....

AH AH great joke.

Thank to ALL
 [2000-08-03 15:00 UTC] waldschrott@php.net
where do you usually store you php.ini, if question is allowed?
 [2000-08-03 15:23 UTC] brunofr at ioda dot net
in my php directory, like this I know everytime and where is my file.
And it work very fine ( with apache of course, not IIS ).

windows is a not a safe directory...
It's too much polluate... 
You know if you work with.


 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Wed Mar 03 08:01:25 2021 UTC