php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #59387 Request for support 1.10-beta string attributes
Submitted: 2010-08-26 05:29 UTC Modified: 2011-03-28 10:05 UTC
From: rauan1987 at gmail dot com Assigned:
Status: Closed Package: sphinx (PECL)
PHP Version: 5.3.3 OS: CentOS 5.5 x86_64
Private report: No CVE-ID: None
 [2010-08-26 05:29 UTC] rauan1987 at gmail dot com
Description:
------------
Current version of client doesn't return fields of sql_field_string type.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-09-08 10:33 UTC] santiago739 at gmail dot com
This bug has been fixed in SVN.

In case this was a documentation problem, the fix will show up at the
end of next Sunday (CET) on pecl.php.net.

In case this was a pecl.php.net website problem, the change will show
up on the website in short time.
 
Thank you for the report, and for helping us make PECL better.

This bug has been fixed in SVN.

Thank you for the report, and for helping us make PECL 
better.
 [2011-01-17 06:50 UTC] rauan1987 at gmail dot com
I still don't see string attributes. Here's var_dump of 
typical doc from search result.

array
  'id' => int 186712
  'weight' => int 925740
  'attrs' => 
    array
      'title' => int 88517768
      'content' => int 88517869
      'tags' => int 88518516
      'username' => int 88518561
      'category_id' => int 14
      ... some fields have been skipped...
      'created' => int 2009

And this is what i've got in sphinx.conf (in source section) 
for some of the fields:

        sql_field_string        = title
        sql_field_string        = content
        sql_field_string        = tags

        sql_attr_string         = username
        sql_attr_timestamp	= created

As you see, it doesn't detect my string fileds and timestamp 
is also incorrect.

Strings are simply character varying of about 100-300 chars.

I'm using latest pecl package 1.1.0
php 5.3.3, centos 5.5 x86_64, sphinx 1.10beta (of course).
 [2011-01-21 06:48 UTC] santiago739 at gmail dot com
It was fixed only in SVN, but has not released yet because of 
beta status sphinx-1.10
So you may check out from svn and compile against sphinx-1.10
And it should be working.
 [2011-03-22 05:01 UTC] hsboss at gmail dot com
Hi,

I'm using centos 5.5 i386.
According to the change log this bug has been fixed(1.1.0 
stable)

But the issue still persists.
 [2011-03-28 10:05 UTC] santiago739 at gmail dot com
I don't see any stable releases of sphinx version 1.10 on the 
sphinxsearch site. Try to install sphinx client from svn  
(http://svn.php.net/viewvc/pecl/sphinx/trunk/)
Perhaps it would make sense to add beta package of sphinx 
extension which supports beta releases of sphinx.
 [2011-06-08 18:25 UTC] pramodg at chug dot net
Hi Santiago
This is in response to Ur last comment on this closed bug - 
"Try to install sphinx client from svn"

Are there any steps that show how to get the bits from svn and 
build it. 

Thanks
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Nov 30 04:03:23 2021 UTC