php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #59366 Ordinal numbering in sv_ locales emits junk
Submitted: 2010-08-14 16:43 UTC Modified: 2012-12-20 14:58 UTC
Votes:2
Avg. Score:4.0 ± 1.0
Reproduced:2 of 2 (100.0%)
Same Version:1 (50.0%)
Same OS:1 (50.0%)
From: michael at dayah dot com Assigned:
Status: Not a bug Package: intl (PECL)
PHP Version: 5.3.2 OS: Ubuntu 10.04
Private report: No CVE-ID: None
 [2010-08-14 16:43 UTC] michael at dayah dot com
Description:
------------
In every other locale other than Swedish, NumberFormatter works for ordinals. In Swedish, it emits an odd string.

Reproduce code:
---------------
$fnf = new NumberFormatter('sv_FI', NumberFormatter::ORDINAL);
echo $fnf->format(1);

$snf = new NumberFormatter('sv_SE', NumberFormatter::ORDINAL);
echo $snf->format(1);

Expected result:
----------------
1st or the Swedish equivalent.

Actual result:
--------------
1:e%digits-ordinal-neutre:0: 1:a

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-01-01 03:46 UTC] hanskrentel at yahoo dot de
I think this is a problem in the underlying ICU Libraries RBNF rules which are 
obtained from CLDR.

Opened a ticket there: http://unicode.org/cldr/trac/ticket/4268
 [2012-05-14 14:11 UTC] hanskrentel at yahoo dot de
On 10 Apr 2012, CLDR trunk on unicode.org has changed the cause of this issue.

http://unicode.org/cldr/trac/changeset/6928/trunk/common/rbnf
 [2012-12-20 14:58 UTC] cataphract@php.net
-Status: Open +Status: Not a bug
 [2012-12-20 14:58 UTC] cataphract@php.net
Closing as the bug is (was) upstream.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Jun 05 23:01:24 2020 UTC