php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #59363 PHP Warning Unknown: GC cache entry
Submitted: 2010-08-11 19:42 UTC Modified: 2016-08-31 15:41 UTC
Votes:15
Avg. Score:4.0 ± 1.0
Reproduced:13 of 13 (100.0%)
Same Version:8 (61.5%)
Same OS:7 (53.8%)
From: noodles at planetslackers dot com Assigned: cmb (profile)
Status: Wont fix Package: APC (PECL)
PHP Version: 5.3.2 OS: RHEL 5.5
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2010-08-11 19:42 UTC] noodles at planetslackers dot com
Description:
------------
I'm intermittently getting these warnings in my php logs:

[11-Aug-2010 09:54:24] PHP Warning:  Unknown: GC cache entry '/home/xxxx/public_html/include/settings.php' (dev=26625 ino=0) was on gc-list for 4657081 seconds in Unknown on line 0 
[11-Aug-2010 09:54:24] PHP Warning:  Unknown: GC cache entry '/home/xxxx/public_html/include/variables.php' (dev=26625 ino=0) was on gc-list for 4664292 seconds in Unknown on line 0 
[11-Aug-2010 09:54:24] PHP Warning:  Unknown: GC cache entry '/home/xxxx/public_html/include/utils.php' (dev=26625 ino=0) was on gc-list for 4664290 seconds in Unknown on line 0 
[11-Aug-2010 09:54:24] PHP Warning:  Unknown: GC cache entry '/home/xxxx/public_html/include/subdomains.php' (dev=26625 ino=0) was on gc-list for 4664288 seconds in Unknown on line 0 

It seems to have happened since I upgraded to PHP 5.3.3 and APC 3.1.4 (I did a pear upgrade after updating PHP).

Expected result:
----------------
I expected not to see any warnings


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-08-13 13:20 UTC] paulgao at yeah dot net
Since APC 3.1.4, Error message logging from stderr to php error.

sometime, apc error message is not need.

I think maybe allow user set error logging to stderr OR php error pipe, just sample:

apc.error_output = STDERR|PHP_LOG
 [2010-08-14 12:41 UTC] paulgao at yeah dot net
apc 3.1.4 change ref to: http://pecl.php.net/bugs/bug.php?id=17527
 [2010-09-15 03:11 UTC] paulgao at yeah dot net
patch for slient run ;)

--- C:/TEMP/apc_c-rev47431.svn000.tmp.c	周三 九月 15 14:51:26 2010
+++ C:/imobile/software/pecl/APC_CVS/apc_cache.c	周三 九月 15 14:47:38 2010
@@ -180,11 +180,15 @@
             if (dead->value->ref_count > 0) {
                 switch(dead->value->type) {
                     case APC_CACHE_ENTRY_FILE:
-                        apc_warning("GC cache entry '%s' (dev=%d ino=%d) was on gc-list for %d seconds" TSRMLS_CC, 
-                            dead->value->data.file.filename, dead->key.data.file.device, dead->key.data.file.inode, gc_sec);
+                        if(APCG(slam_defense)) {
+                            apc_warning("GC cache entry '%s' (dev=%d ino=%d) was on gc-list for %d seconds" TSRMLS_CC,
+                                dead->value->data.file.filename, dead->key.data.file.device, dead->key.data.file.inode, gc_sec);
+                        }
                         break;
                     case APC_CACHE_ENTRY_USER:
-                        apc_warning("GC cache entry '%s'was on gc-list for %d seconds" TSRMLS_CC, dead->value->data.user.info, gc_sec);
+                        if(APCG(slam_defense)) {
+                            apc_warning("GC cache entry '%s'was on gc-list for %d seconds" TSRMLS_CC, dead->value->data.user.info, gc_sec);
+                        }
                         break;
                 }
             }
 [2016-08-31 15:41 UTC] cmb@php.net
-Status: Open +Status: Wont fix -Assigned To: +Assigned To: cmb
 [2016-08-31 15:41 UTC] cmb@php.net
According to <https://bugs.php.net/69618>, APC support has been
discontinued in favor of OPcache, APCu, the session upload
progress API and WinCache. Therefore this issue won't get fixed.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Nov 30 00:03:14 2021 UTC