php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #59258 Cannot install solr-0.9.10 on system with libtool 2.2.6b
Submitted: 2010-06-08 08:55 UTC Modified: 2011-06-04 04:26 UTC
From: oleg at bintime dot com Assigned: iekpo (profile)
Status: Not a bug Package: solr (PECL)
PHP Version: 5.2.13 OS: Gentoo 2.6.32-gentoo-r2 x86_64
Private report: No CVE-ID: None
 [2010-06-08 08:55 UTC] oleg at bintime dot com
Description:
------------
Hello,

Could you please help me to install solr extension?

I tried to install it via pecl:

# pecl install solr-beta
downloading solr-0.9.10.tgz ...
Starting to download solr-0.9.10.tgz (96,368 bytes)
.....................done: 96,368 bytes
28 source files, building
WARNING: php_bin /usr/lib64/php5/bin/php appears to have a suffix 5/bin/php, but config variable php_suffix does not match
running: phpize
Configuring for:
PHP Api Version:         20041225
Zend Module Api No:      20060613
Zend Extension Api No:   220060519
Enable Solr (yes of course) [yes] : 
Enable Solr Debugging (Compiles solr in debug mode) [no] : 
libcURL install prefix [/usr] : 
libxml2 install prefix [/usr] : 

After this ./configure goes fine but then during 'make' I get:

running: make
/bin/sh /var/tmp/pear-build-root/solr-0.9.10/libtool --mode=compile cc  -I. -I/tmp/solr -DPHP_ATOM_INC -I/var/tmp/pear-build-root/solr-0.9.10/include -I/var/tmp/pear-build-root/solr-0.9.10/main -I/tmp/solr -I/usr/lib64/php5/include/php -I/usr/lib64/php5/include/php/main -I/usr/lib64/php5/include/php/TSRM -I/usr/lib64/php5/include/php/Zend -I/usr/lib64/php5/include/php/ext -I/usr/lib64/php5/include/php/ext/date/lib -I/usr/include/libxml2  -DHAVE_CONFIG_H  -g -O2   -c /tmp/solr/php_solr.c -o php_solr.lo
/var/tmp/pear-build-root/solr-0.9.10/libtool: line 467: CDPATH: command not found
/var/tmp/pear-build-root/solr-0.9.10/libtool: line 1152: func_opt_split: command not found
libtool: Version mismatch error.  This is libtool 2.2.6b, but the
libtool: definition of this LT_INIT comes from an older release.
libtool: You should recreate aclocal.m4 with macros from libtool 2.2.6b
libtool: and run autoconf again.
make: *** [php_solr.lo] Error 63
ERROR: `make' failed

As I understood this should be fixed by the developer. If you can tell how to fix this, would be great.

Also, I tried to download source code from pecl.php.net. So I unpack it and then I have to run ./configure manually but there is no configure executable inside the package..

Any help would be highly appreciated.

libcurl: 7.20.0-r2
libxml2: 2.7.7

Thanks in advance,
Oleg

Reproduce code:
---------------
pecl install solr-beta

Expected result:
----------------
Solr PHP extension isntalled and working

Actual result:
--------------
/bin/sh /var/tmp/pear-build-root/solr-0.9.10/libtool --mode=compile cc  -I. -I/tmp/solr -DPHP_ATOM_INC -I/var/tmp/pear-build-root/solr-0.9.10/include -I/var/tmp/pear-build-root/solr-0.9.10/main -I/tmp/solr -I/usr/lib64/php5/include/php -I/usr/lib64/php5/include/php/main -I/usr/lib64/php5/include/php/TSRM -I/usr/lib64/php5/include/php/Zend -I/usr/lib64/php5/include/php/ext -I/usr/lib64/php5/include/php/ext/date/lib -I/usr/include/libxml2  -DHAVE_CONFIG_H  -g -O2   -c /tmp/solr/php_solr.c -o php_solr.lo
/var/tmp/pear-build-root/solr-0.9.10/libtool: line 467: CDPATH: command not found
/var/tmp/pear-build-root/solr-0.9.10/libtool: line 1152: func_opt_split: command not found
libtool: Version mismatch error.  This is libtool 2.2.6b, but the
libtool: definition of this LT_INIT comes from an older release.
libtool: You should recreate aclocal.m4 with macros from libtool 2.2.6b
libtool: and run autoconf again.
make: *** [php_solr.lo] Error 63


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-06-08 10:43 UTC] iekpo@php.net
It looks like you need to upgrade your libtool version.

Then download the package and run the following commands

tar -zxvf solr.tar.gz (for whatever the filename is)

cd solr.0.9.10

phpize 

./configure

make && make install

The phpize command should create the configure script for you but it looks like you need to set up the right version of libtool first. Also make sure that you have automake and autoconf set up correctly.
 [2010-06-08 12:38 UTC] oleg at bintime dot com
Hello and thanks for your reply!

I've upgraded libtool from 2.2.6b to 2.2.8 and the problem is still there.. Can it be that my libtool version is too new? The error message suggests to "recreate aclocal.m4 with macros from libtool 2.2.6b" - should this be done by you or by user?
I hope that automake and autoconf are set up correctly on this system because there were no problems during compilations.

So the question is: do you think this may be due to new libtool version on my machine and solr package itself has to be updated in some way?
 [2010-06-14 06:03 UTC] oleg at bintime dot com
Hello,

Sorry to be a pain but did you find time to check this issue?
 [2011-06-04 04:26 UTC] iekpo@php.net
Sorry, but your problem does not imply a bug in PECL itself.  For a
list of more appropriate places to ask for help using PECL, please
visit http://pecl.php.net/support.php as this bug system is not the
appropriate forum for asking support questions. 

Thank you for your interest in PECL.

I dont think this is a problem with the code.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Dec 04 08:01:23 2020 UTC