php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #59209 Restore compatibility with old sphinxapi.php
Submitted: 2010-05-12 11:18 UTC Modified: 2010-05-12 13:09 UTC
From: daditto at gmail dot com Assigned:
Status: Closed Package: sphinx (PECL)
PHP Version: 5.2.6 OS: debian lenny
Private report: No CVE-ID: None
 [2010-05-12 11:18 UTC] daditto at gmail dot com
Description:
------------
I just installed a PECL version of sphinx and it seems to be incompatible with an older version of sphinxapi.php. Not a single application (IPB 3.0.5, Livestreet 0.4) that used older sphinxapi.php worked. 

Here's my investigation and proposal:

1) Create older shortcut function setWeights(array()) to a new setIndexWeights(int,int) for compatibility.

2) setLimits function with only two parameters specified (offset and limit) returns a error: per-query max_matches=0 out of bounds (per-server max_matches=1000000). $max_matches default value of 0 should be either set to reasonable value or ignored and set as in "per-sever"

Reproduce code:
---------------
Install pecl version of sphinx

Expected result:
----------------
Applications that use older sphinxapi.php syntax to work

Actual result:
--------------
They don't work

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-05-12 13:09 UTC] daditto at gmail dot com
This seem to be related to 0.9.8 version of Sphinx and fixed in 0.9.9
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Nov 30 02:03:13 2021 UTC