php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #59180 wincache_lock/wincache_unlock to take additional parameter as time
Submitted: 2010-04-26 16:38 UTC Modified: 2014-02-20 17:38 UTC
Votes:3
Avg. Score:4.3 ± 0.9
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: donraman@php.net Assigned: ericsten (profile)
Status: Wont fix Package: WinCache (PECL)
PHP Version: Trunk SVN-2010-04-26 (dev) OS: Windows
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2010-04-26 16:38 UTC] donraman@php.net
Description:
------------
Two wincache API namely
1. wincache_lock
2. wincache_unlock

to take an additional parameter named time which defines for how long a process will wait before dying out when acquiring a lock. The time can be in milliseconds.

Since we are using API WaitForSingleObject we can implement this and it will also prevent deadlock.

This request came from Drupal developers. I am filing this bug for better tracking purpose. This is not a must have feature but rather nice to have.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-08-28 21:37 UTC] mitukura at siren dot ocn dot ne dot jp
http://www.findmedsnow.net/ what is prednisone used for >:-PP http://www.medsconnect.net/ synthroid 9041
 [2011-08-29 20:34 UTC] mirai at mk-green dot net
http://www.pillsmarket.net/ zovirax lxj http://www.medsonweb.com/ purchase cymbalta =O
 [2011-09-01 20:35 UTC] print at hirayama dot info
http://www.gethealthonline.net/ seroquel 8470 http://www.lexprices.com/ lexapro kvxv
 [2011-09-14 20:49 UTC] day-hanahana at kej dot biglobe dot ne dot jp
http://www.medicsupport.net/ prednisone 8-]]] http://www.halfpricemed.com/ viagra :PP
 [2011-09-15 22:04 UTC] day-hanahana at kej dot biglobe dot ne dot jp
http://www.halfpricemed.com/ viagra for woman 19740 http://www.qualitytablets.net/ lexapro xadfg
 [2014-02-20 17:38 UTC] ericsten@php.net
-Status: Open +Status: Wont fix -Assigned To: +Assigned To: ericsten
 [2014-02-20 17:38 UTC] ericsten@php.net
This feature request has sat for 4 years, so putting it out of its misery now...
Thx!
    --E.
 [2014-02-20 17:38 UTC] ericsten@php.net
-Block user comment: No +Block user comment: Yes
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Wed Apr 24 22:01:26 2019 UTC