php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #59140 SASL support
Submitted: 2010-03-31 09:45 UTC Modified: 2012-03-07 17:28 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: gabriele at pierfederici dot com Assigned: andrei (profile)
Status: Closed Package: memcached (PECL)
PHP Version: 5.2.0 OS: linux
Private report: No CVE-ID: None
 [2010-03-31 09:45 UTC] gabriele at pierfederici dot com
Description:
------------
it would be great to have support for memcached built with --
enable-sasl (http://gist.github.com/209099), I believe SASL 
has been implemented in libmemcached already.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-03-31 10:30 UTC] aotto at aotto dot vcom
I agree this would be a great addition.
 [2010-06-16 08:39 UTC] cronfy at gmail dot com
libmemcached supports SASL since 0.39: 
https://launchpad.net/libmemcached/+announcement/5548

Hope to see it in memcached soon.
 [2010-09-14 17:15 UTC] tw at cloudcontrol dot de
I have started with an implementation of sasl for the php-
memcached package. You can find the fork at 
http://github.com/twcc/php-memcached . 

To bad the sasl implementation in libmemcached was broken in 
the version 0.43. I fixed this, too. You can find this at 
https://code.launchpad.net/~tw/libmemcached/sasl. One of the 
top contributors merged the patch to his repository if you 
prefer https://code.launchpad.net/~trond-
norbye/libmemcached/mingw32.

The implementation is tested with sasl2 and the NorthScale 
Memcached Server.
 [2012-03-07 17:28 UTC] andrei@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: andrei
 [2012-03-07 17:28 UTC] andrei@php.net
Implemented in 2.0.x.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Aug 14 21:01:24 2020 UTC