php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #5912 Parse fails when FF (ASCII 12) character is in between <? ?>
Submitted: 2000-08-02 00:02 UTC Modified: 2000-08-02 17:29 UTC
From: tswan at ics dot olemiss dot edu Assigned:
Status: Closed Package: Scripting Engine problem
PHP Version: 4.0 Latest CVS (01/08/2000) OS: Linux (2.2.16)
Private report: No CVE-ID:
 [2000-08-02 00:02 UTC] tswan at ics dot olemiss dot edu
<?
{Insert ASCII 12}
echo "Hi!";
?>

I had hoped or rather assumed that PHP would skip over this character as a whitespace...
I use FF characters to paginate source on print out... 

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-08-02 17:29 UTC] stas@php.net
It doesn't fail, it produces warning. And this is intended behaviour. If you want it to be changed, submit change request.
 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Sun Apr 20 21:01:56 2014 UTC