php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #59077 Make FAILS
Submitted: 2010-02-19 13:01 UTC Modified: 2010-06-08 18:56 UTC
From: peter dot urda at gmail dot com Assigned: jluedke
Status: Closed Package: gearman (PECL)
PHP Version: 5.2.10 OS: Ubuntu 9.10
Private report: No CVE-ID:
 [2010-02-19 13:01 UTC] peter dot urda at gmail dot com
Description:
------------
Checked out revision 295259.

PHP 5.2.10-2ubuntu6.4 with Suhosin-Patch 0.9.7 (cli) (built: Jan  6 2010 22:41:56) 
Copyright (c) 1997-2009 The PHP Group
Zend Engine v2.2.0, Copyright (c) 1998-2009 Zend Technologies

Ubuntu 9.10 32bit

---
MAKE error below!

/home/facilityone/gearman-php-trunk/php_gearman.c:910: error: expected specifier-qualifier-list before \u2018gearman_universal_st\u2019
/home/facilityone/gearman-php-trunk/php_gearman.c: In function \u2018zm_startup_gearman\u2019:
/home/facilityone/gearman-php-trunk/php_gearman.c:4480: error: \u2018GEARMAN_VERBOSE_NEVER\u2019 undeclared (first use in this function)
/home/facilityone/gearman-php-trunk/php_gearman.c:4480: error: (Each undeclared identifier is reported only once
/home/facilityone/gearman-php-trunk/php_gearman.c:4480: error: for each function it appears in.)


Reproduce code:
---------------
svn co http://svn.php.net/repository/pecl/gearman/trunk

sudo su
phpize
./configure
make (FAILS HERE)
make install


Expected result:
----------------
Build Gearman Extension.

Actual result:
--------------
Doesn't build Gearman Extension

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-02-19 13:25 UTC] contact at jamesluedke dot com
This bug has been fixed in SVN.

In case this was a documentation problem, the fix will show up at the
end of next Sunday (CET) on pecl.php.net.

In case this was a pecl.php.net website problem, the change will show
up on the website in short time.
 
Thank you for the report, and for helping us make PECL better.

strange, built fine with 5.3. I removed the unused object that was causing the error. Please try again.
 [2010-02-26 10:16 UTC] peter dot urda at gmail dot com
SVN:
Checked out revision 295535.

Make Error again:

:~/gearman-php-trunk2$ make
/bin/bash /home/facilityone/gearman-php-trunk2/libtool --mode=compile cc  -I. -I/home/facilityone/gearman-php-trunk2 -DPHP_ATOM_INC -I/home/facilityone/gearman-php-trunk2/include -I/home/facilityone/gearman-php-trunk2/main -I/home/facilityone/gearman-php-trunk2 -I/usr/include/php5 -I/usr/include/php5/main -I/usr/include/php5/TSRM -I/usr/include/php5/Zend -I/usr/include/php5/ext -I/usr/include/php5/ext/date/lib -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64  -DHAVE_CONFIG_H  -g -O2 -Wall   -c /home/facilityone/gearman-php-trunk2/php_gearman.c -o php_gearman.lo 
libtool: compile:  cc -I. -I/home/facilityone/gearman-php-trunk2 -DPHP_ATOM_INC -I/home/facilityone/gearman-php-trunk2/include -I/home/facilityone/gearman-php-trunk2/main -I/home/facilityone/gearman-php-trunk2 -I/usr/include/php5 -I/usr/include/php5/main -I/usr/include/php5/TSRM -I/usr/include/php5/Zend -I/usr/include/php5/ext -I/usr/include/php5/ext/date/lib -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -DHAVE_CONFIG_H -g -O2 -Wall -c /home/facilityone/gearman-php-trunk2/php_gearman.c  -fPIC -DPIC -o .libs/php_gearman.o
/home/facilityone/gearman-php-trunk2/php_gearman.c: In function \u2018zm_startup_gearman\u2019:
/home/facilityone/gearman-php-trunk2/php_gearman.c:4475: error: \u2018GEARMAN_VERBOSE_NEVER\u2019 undeclared (first use in this function)
/home/facilityone/gearman-php-trunk2/php_gearman.c:4475: error: (Each undeclared identifier is reported only once
/home/facilityone/gearman-php-trunk2/php_gearman.c:4475: error: for each function it appears in.)
make: *** [php_gearman.lo] Error 1
 [2010-03-19 14:05 UTC] peter dot urda at gmail dot com
Still getting make error :(

Revision from trunk was: 296438

==

gearman-php-trunk# make
/bin/bash /home/peter/gearman-php-trunk/libtool --mode=compile cc  -I. -I/home/peter/gearman-php-trunk -DPHP_ATOM_INC -I/home/peter/gearman-php-trunk/include -I/home/peter/gearman-php-trunk/main -I/home/peter/gearman-php-trunk -I/usr/include/php5 -I/usr/include/php5/main -I/usr/include/php5/TSRM -I/usr/include/php5/Zend -I/usr/include/php5/ext -I/usr/include/php5/ext/date/lib -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64  -DHAVE_CONFIG_H  -g -O2 -Wall   -c /home/peter/gearman-php-trunk/php_gearman.c -o php_gearman.lo 
libtool: compile:  cc -I. -I/home/peter/gearman-php-trunk -DPHP_ATOM_INC -I/home/peter/gearman-php-trunk/include -I/home/peter/gearman-php-trunk/main -I/home/peter/gearman-php-trunk -I/usr/include/php5 -I/usr/include/php5/main -I/usr/include/php5/TSRM -I/usr/include/php5/Zend -I/usr/include/php5/ext -I/usr/include/php5/ext/date/lib -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -DHAVE_CONFIG_H -g -O2 -Wall -c /home/peter/gearman-php-trunk/php_gearman.c  -fPIC -DPIC -o .libs/php_gearman.o
/home/peter/gearman-php-trunk/php_gearman.c: In function ‘zm_startup_gearman’:
/home/peter/gearman-php-trunk/php_gearman.c:4467: error: ‘GEARMAN_VERBOSE_NEVER’ undeclared (first use in this function)
/home/peter/gearman-php-trunk/php_gearman.c:4467: error: (Each undeclared identifier is reported only once
/home/peter/gearman-php-trunk/php_gearman.c:4467: error: for each function it appears in.)
make: *** [php_gearman.lo] Error 1
 [2010-05-03 13:32 UTC] mweierophinney at gmail dot com
I've tried compiling on Ubuntu 9.10, via a Zend Server PHP 
5.3.2 build. I've got the gearman, gearman-job-server, 
gearman-tools, libgearman-dev, libgearman-server-dev, 
libgearman-server0, and libgearman2 ubuntu packages 
installed; they are built off the 0.10 releases of gearmand. 

I have tried compiling the 0.7.0 release, 0.6.0 release, 0.5 
release, and current trunk. In all cases, I run into compile 
errors; 0.6.0, 0.7.0, and trunk have the same errors, and 
are exactly as reported in the 2nd and 3rd comments of this 
report.
 [2010-05-03 13:57 UTC] mweierophinney at gmail dot com
This appears to be an issue with the libgearman packages on 
ubuntu. When I build gearman from source and compile the 
extension against it, I get no errors, and all compiles as 
expected.
 [2010-05-03 14:18 UTC] mweierophinney at gmail dot com
Using the gearman PPA (https://launchpad.net/~gearman-
developers/+archive/ppa) instead of the Ubuntu gearman 
packages also solves the issues with build.
 [2010-05-10 06:43 UTC] andreas dot cederstrom at fronter dot com
Im getting this:


/bin/sed: can't read /usr/lib/libuuid.la: No such file or 
directory
libtool: link: `/usr/lib/libuuid.la' is not a valid libtool 
archive


When I do this:

svn co http://svn.php.net/repository/pecl/gearman/trunk

sudo su
phpize
./configure
make (FAILS HERE)
make install


Googled a little about libuuid.la, seems it has been removed 
in ubuntu 10.04 because debian has some policy that they 
shouldnt have .la files. yes, i have all the uuid packages 
installed, even -dev.
 [2010-06-08 18:56 UTC] felipe@php.net
This bug has been fixed in SVN.

In case this was a documentation problem, the fix will show up at the
end of next Sunday (CET) on pecl.php.net.

In case this was a pecl.php.net website problem, the change will show
up on the website in short time.
 
Thank you for the report, and for helping us make PECL better.


 [2011-02-06 16:56 UTC] mail at lornajane dot net
I had issues on Ubuntu 10.04 - using the gearman-developers ppa helped but I needed the drizzle-developers ppa as well, and then pecl installed fine.  I had no problems at all with Ubuntu 10.10.
 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Thu Apr 17 21:01:56 2014 UTC