php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #59073 Make error with PHP 5.3.1
Submitted: 2010-02-10 16:53 UTC Modified: 2012-05-25 13:00 UTC
From: wloche@php.net Assigned: pierrick (profile)
Status: Closed Package: mqseries (PECL)
PHP Version: 5_3.1RC2 OS: Linux (SUSE10 SP2)
Private report: No CVE-ID: None
 [2010-02-10 16:53 UTC] wloche@php.net
Description:
------------
Hi,

I tried to compile your extension upon PHP 5.3.1 and it failed.

Thx,
Wilfried Loche


Reproduce code:
---------------
/ehc/fs1/softs/spms/php_robot/bin/phpize

sed -i "s/\$MQSERIES_DIR\/lib/\$MQSERIES_DIR\/lib64/g" ./configure    

./configure --with-php-config=/ehc/fs1/softs/spms/php_robot/bin/php-config --with-libdir=lib64

make -j 8



Expected result:
----------------
Build complete.
Don't forget to run 'make test'.


Actual result:
--------------
/bin/sh /ehc/fs1/home/spms/deploy/spms/SPMS-MW/pecl/mqseries-0.11.0/libtool --mode=compile cc  -I. -I/ehc/fs1/home/spms/deploy/spms/SPMS-MW/pecl/mqseries-0.11.0 -DPHP_ATOM_INC -I/ehc/fs1/home/spms/deploy/spms/SPMS-MW/pecl/mqseries-0.11.0/include -I/ehc/fs1/home/spms/deploy/spms/SPMS-MW/pecl/mqseries-0.11.0/main -I/ehc/fs1/home/spms/deploy/spms/SPMS-MW/pecl/mqseries-0.11.0 -I/ehc/fs1/softs/spms/php-5.3.1/include/php -I/ehc/fs1/softs/spms/php-5.3.1/include/php/main -I/ehc/fs1/softs/spms/php-5.3.1/include/php/TSRM -I/ehc/fs1/softs/spms/php-5.3.1/include/php/Zend -I/ehc/fs1/softs/spms/php-5.3.1/include/php/ext -I/ehc/fs1/softs/spms/php-5.3.1/include/php/ext/date/lib -I/opt/mqm/inc  -DHAVE_CONFIG_H  -g -O2   -c /ehc/fs1/home/spms/deploy/spms/SPMS-MW/pecl/mqseries-0.11.0/mqseries.c -o mqseries.lo
 cc -I. -I/ehc/fs1/home/spms/deploy/spms/SPMS-MW/pecl/mqseries-0.11.0 -DPHP_ATOM_INC -I/ehc/fs1/home/spms/deploy/spms/SPMS-MW/pecl/mqseries-0.11.0/include -I/ehc/fs1/home/spms/deploy/spms/SPMS-MW/pecl/mqseries-0.11.0/main -I/ehc/fs1/home/spms/deploy/spms/SPMS-MW/pecl/mqseries-0.11.0 -I/ehc/fs1/softs/spms/php-5.3.1/include/php -I/ehc/fs1/softs/spms/php-5.3.1/include/php/main -I/ehc/fs1/softs/spms/php-5.3.1/include/php/TSRM -I/ehc/fs1/softs/spms/php-5.3.1/include/php/Zend -I/ehc/fs1/softs/spms/php-5.3.1/include/php/ext -I/ehc/fs1/softs/spms/php-5.3.1/include/php/ext/date/lib -I/opt/mqm/inc -DHAVE_CONFIG_H -g -O2 -c /ehc/fs1/home/spms/deploy/spms/SPMS-MW/pecl/mqseries-0.11.0/mqseries.c  -fPIC -DPIC -o .libs/mqseries.o
/ehc/fs1/home/spms/deploy/spms/SPMS-MW/pecl/mqseries-0.11.0/mqseries.c:99: error: duplicate 'static'
/ehc/fs1/home/spms/deploy/spms/SPMS-MW/pecl/mqseries-0.11.0/mqseries.c:106: error: duplicate 'static'
/ehc/fs1/home/spms/deploy/spms/SPMS-MW/pecl/mqseries-0.11.0/mqseries.c:114: error: duplicate 'static'
/ehc/fs1/home/spms/deploy/spms/SPMS-MW/pecl/mqseries-0.11.0/mqseries.c:123: error: duplicate 'static'
/ehc/fs1/home/spms/deploy/spms/SPMS-MW/pecl/mqseries-0.11.0/mqseries.c:130: error: duplicate 'static'
/ehc/fs1/home/spms/deploy/spms/SPMS-MW/pecl/mqseries-0.11.0/mqseries.c:138: error: duplicate 'static'
/ehc/fs1/home/spms/deploy/spms/SPMS-MW/pecl/mqseries-0.11.0/mqseries.c:147: error: duplicate 'static'
/ehc/fs1/home/spms/deploy/spms/SPMS-MW/pecl/mqseries-0.11.0/mqseries.c:154: error: duplicate 'static'
/ehc/fs1/home/spms/deploy/spms/SPMS-MW/pecl/mqseries-0.11.0/mqseries.c:167: error: duplicate 'static'
/ehc/fs1/home/spms/deploy/spms/SPMS-MW/pecl/mqseries-0.11.0/mqseries.c:181: error: duplicate 'static'
/ehc/fs1/home/spms/deploy/spms/SPMS-MW/pecl/mqseries-0.11.0/mqseries.c:191: error: duplicate 'static'
/ehc/fs1/home/spms/deploy/spms/SPMS-MW/pecl/mqseries-0.11.0/mqseries.c:202: error: duplicate 'static'
/ehc/fs1/home/spms/deploy/spms/SPMS-MW/pecl/mqseries-0.11.0/mqseries.c:214: error: duplicate 'static'
make: *** [mqseries.lo] Error 1


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-12-20 13:21 UTC] paul dot wieland at us dot atlascopco dot com
Same problem, no updates? Is this extension dead?
 [2010-12-20 14:01 UTC] paul dot wieland at us dot atlascopco dot com
SOLVED: 

I got it to compile by removing the 'static' calls from 
mqseries.c


For example, I changed:

/* {{{ arginfo */
static
ZEND_BEGIN_ARG_INFO_EX(arginfo_mqseries_back, 0 ,0, 3)


to:


/* {{{ arginfo */

ZEND_BEGIN_ARG_INFO_EX(arginfo_mqseries_back, 0 ,0, 3)


Repeat for all static declarations near ZEND_

Got the idea after reading this:
http://devlog.mahcuz.com/2010/08/php-gtk-compile-error-
duplicate-static/

Also noticed that a bunch of other pecl packages suffer from 
the same exact compile errors, 
so I looked at what those dev's did to solve the problem (I 
did a diff on inotify 1.4 vs 
1.3).
 [2012-05-25 13:00 UTC] pierrick@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: pierrick
 [2012-05-25 13:00 UTC] pierrick@php.net
This bug has been fixed in SVN.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.

 For Windows:

http://windows.php.net/snapshots/
 
Thank you for the report, and for helping us make PHP better.

Fixed in revision 325803. This will be part of 0.12.0
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun May 19 17:01:26 2019 UTC