php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #59063 Select of too many fields
Submitted: 2010-02-04 15:09 UTC Modified: 2017-04-01 21:19 UTC
Votes:3
Avg. Score:3.0 ± 1.6
Reproduced:1 of 2 (50.0%)
Same Version:1 (100.0%)
Same OS:0 (0.0%)
From: jason at feets dot com Assigned:
Status: Wont fix Package: PDO_4D (PECL)
PHP Version: 5.3.0 OS: XP
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2010-02-04 15:09 UTC] jason at feets dot com
Description:
------------
When calling SELECT * on a table with more than 60 or so 
fields the httpd throws an exception. More specifically I have 
2 tables, one has 73 fields and the other has 86.
I have found when calling the table with 73 fields using 
Select Field_1,...,Field_N I can include 61 fields before it 
breaks.
On the table with 86 It breaks when 58 fields are included.
I have tested this with the DLL that was provided to us 
compiled in vc9 as well as a version of the dll that I 
compiled using vc6. Similar results for both (total number of 
fields varied slightly).

Reproduce code:
---------------
$ttDSN = '4D:host=' . $ttHost . ';charset=UTF-8';	
try
{
   $xlConnID = new PDO($ttDSN, $ttUser, $ttPass);
}

$ttSQL = "SELECT * FROM Projects ORDER BY SeqNum";
$xlRows = $xlConnID->prepare($ttSQL);
$xlRows->execute();	

foreach($xlConnID->query($ttSQL) as $xlRow)
{
	print $xlRow[0] . $t;
	print $xlRow[1] . $t;
	print $xlRow[2] . $t;
	print $xlRow[3] . $t;
	print $xlRow[4] . $t;
}

Expected result:
----------------
Listing of data from the records
Field0 Field1 Field2 Field3 Field4 

Actual result:
--------------
JIT debugger on server machine (WinXP Running default install 
of WAMPServer2.0i + php_pdo_4d.dll

Unhandled win32 exception occured in httpd.exe [4492]

First MSVS error dialog:
Unhandled exception at 0x019c723d in httpd.exe: 0xC0000005: 
Accessviolation reading location 0x00000000. 

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2017-04-01 21:19 UTC] tpunt@php.net
-Status: Open +Status: Wont fix
 [2017-04-01 21:19 UTC] tpunt@php.net
Due to this extension not seeing any activity since 2009, this issue will not be fixed. We are therefore closing this now.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Mon Nov 18 21:01:37 2019 UTC