|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #59052 2.2.5 only works for *first* session then fails
Submitted: 2010-01-30 22:06 UTC Modified: 2013-02-18 00:35 UTC
From: apinstein at mac dot com Assigned:
Status: No Feedback Package: memcache (PECL)
PHP Version: 5.2.11 OS: Mac OS X 10.5
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please — but make sure to vote on the bug!
Your email address:
Solve the problem:
27 + 44 = ?
Subscribe to this entry?

 [2010-01-30 22:06 UTC] apinstein at mac dot com
session_start() fails on all but first request in session.

Reproduce code:
I did a pecl install memcache (2.2.5) and added this to my app:

ini_set('session.save_handler', 'memcache');
ini_set('session.save_path', 'tcp://');

The first time a session is created, the page loads fine. Subsequent requests in the same session fail in session_start() with "Operation now in progress (36)".

I have isolated this problem to 2.2.5 by:
1) switching out the backend for toyko tyrant (which is memcache protocol compliant) -- same bug
1a) If I clear my session cookie it *works* the first time (although that does no good since it's a session).
2) downgrading to 2.2.4 -- works
3) I tried 3.0.4 but it wouldn't build so I didn't bother since 2.2.4 fixed it.

Expected result:
Sessions should work.

Actual result:
Subsequent requests in the same session fail in 
session_start() with "Operation now in progress (36)".


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2011-03-10 22:12 UTC]
Please try 2.2.6.

Also, does the script below reproduce the failure?  I can't tell exactly what "session_start() fails on all but first request in session." means.

ini_set('session.save_handler', 'memcache');
ini_set('session.save_path', 'tcp://');

session_start(); // <--- failure caused here
 [2013-02-18 00:35 UTC] pecl-dev at lists dot php dot net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Wed May 22 21:01:31 2024 UTC