php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #59021 zip problem install
Submitted: 2010-01-06 05:31 UTC Modified: 2013-10-23 07:55 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: cartman29 at voila dot fr Assigned:
Status: Not a bug Package: zip (PECL)
PHP Version: 5.2.4 OS: ubuntu 8.04.3
Private report: No CVE-ID: None
 [2010-01-06 05:31 UTC] cartman29 at voila dot fr
Description:
------------
I can't install zip : here the error 

 

Reproduce code:
---------------
root@OCS:/home/mai# pecl install zip
downloading zip-1.10.2.tgz ...
Starting to download zip-1.10.2.tgz (236,912 bytes)
..................done: 236,912 bytes
61 source files, building
running: phpize
Configuring for:
PHP Api Version:         20041225
Zend Module Api No:      20060613
Zend Extension Api No:   220060519
building in /var/tmp/pear-build-root/zip-1.10.2
running: /tmp/pear/temp/zip/configure
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for a sed that does not truncate output... /bin/sed

Expected result:
----------------
/tmp/pear/temp/zip/php_zip.c:601: erreur: ?pcre? undeclared (first use in this function)
/tmp/pear/temp/zip/php_zip.c:601: erreur: (Each undeclared identifier is reported only once
/tmp/pear/temp/zip/php_zip.c:601: erreur: for each function it appears in.)
/tmp/pear/temp/zip/php_zip.c:601: erreur: ?re? undeclared (first use in this function)
/tmp/pear/temp/zip/php_zip.c:602: erreur: ?pcre_extra? undeclared (first use in this function)
/tmp/pear/temp/zip/php_zip.c: Hors de toute fonction :
/tmp/pear/temp/zip/php_zip.c:1112: attention : initialization discards qualifiers from pointer target type
/tmp/pear/temp/zip/php_zip.c: Dans la fonction ?zm_startup_zip? :
/tmp/pear/temp/zip/php_zip.c:2586: attention : assignment discards qualifiers from pointer target type
make: *** [php_zip.lo] Erreur 1
ERROR: `make' failed
root@OCS:/home/mai# 


Actual result:
--------------
make: *** [php_zip.lo] Erreur 1
ERROR: `make' failed

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-01-06 07:37 UTC] cartman29 at voila dot fr
I have resolve it : sudo apt-get install libpcre3 libpcre3-dev
 [2013-10-23 07:55 UTC] remi@php.net
-Status: Open +Status: Not a bug
 [2013-10-23 07:55 UTC] remi@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Jan 17 22:01:22 2020 UTC