php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #58979 libtool: Version mismatch error
Submitted: 2009-12-05 11:39 UTC Modified: 2016-11-30 18:43 UTC
Votes:4
Avg. Score:4.2 ± 0.8
Reproduced:3 of 3 (100.0%)
Same Version:0 (0.0%)
Same OS:2 (66.7%)
From: rebel29270 at orange dot fr Assigned: cmb (profile)
Status: Not a bug Package: uploadprogress (PECL)
PHP Version: 5.2.11 OS: gentoo
Private report: No CVE-ID: None
 [2009-12-05 11:39 UTC] rebel29270 at orange dot fr
Description:
------------
wget http://pecl.php.net/get/uploadprogress
tar -xvzf uploadprogress
cd ./uploadprogress-1.0.1
phpize
./configure
make
PROBLEM ->
/bin/sh /var/tmp/pear-build-root/uploadprogress-1.0.1/libtool --mode=compile cc  -I. -I/tmp/pear/download/uploadprogress-1.0.1 -DPHP_ATOM_INC -I/var/tmp/pear-build-root/uploadprogress-1.0.1/include -I/var/tmp/pear-build-root/uploadprogress-1.0.1/main -I/tmp/pear/download/uploadprogress-1.0.1 -I/usr/lib64/php5/include/php -I/usr/lib64/php5/include/php/main -I/usr/lib64/php5/include/php/TSRM -I/usr/lib64/php5/include/php/Zend -I/usr/lib64/php5/include/php/ext -I/usr/lib64/php5/include/php/ext/date/lib  -DHAVE_CONFIG_H  -g -O2   -c /tmp/pear/download/uploadprogress-1.0.1/uploadprogress.c -o uploadprogress.lo
/var/tmp/pear-build-root/uploadprogress-1.0.1/libtool: line 460: CDPATH: command not found
/var/tmp/pear-build-root/uploadprogress-1.0.1/libtool: line 1145: func_opt_split: command not found
libtool: Version mismatch error.  This is libtool 2.2.6, but the
libtool: definition of this LT_INIT comes from an older release.
libtool: You should recreate aclocal.m4 with macros from libtool 2.2.6
libtool: and run autoconf again.
make: *** [uploadprogress.lo] Error 63
ERROR: `make' failed


after an autoconf same problem...

same problem on "pecl install uploadprogress" launch

Actual result:
--------------
cant's install

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2010-02-10 13:28 UTC] okleinecke at web dot de
Just wanted to confirm this bug, having the same issue on my gentoo-stage3-server here. Will try to fix it myself now.
 [2010-02-10 13:36 UTC] okleinecke at web dot de
Sorry, just found out that this is DEFINITELY related to a gentoo phpize/libtool error. Bug report can be closed.
 [2010-02-10 14:08 UTC] okleinecke at web dot de
Just managed to get uploadprogress-extension installed the following way :

wget http://pecl.php.net/get/uploadprogress
tar -xvzf uploadprogress
cd ./uploadprogress-1.0.1
phpize
aclocal
libtoolize --force
autoheader
autoconf
make && make install

.. works :) !
 [2010-02-22 15:30 UTC] emilianoromero at gmail dot com
Hi!, I know it's not a problem of pecl, but when I search in 
google i just get here. So like there should be more people 
with this problem, I post a quick workarround.
# pecl download <extension>
# tar xf <extension>.tar
# cd <extensiondir>
# phpize
# vi libtool
Here we have to fix VERSION variable and put the value in 
macro_version variable. We also need to fix package_revision 
variable and put the value in macro_revision.
# ./configure
# make

With that I could compile my extensions correctly.

Regards, hope this helps someone.
 [2010-04-04 05:51 UTC] gentoo at oliwel dot de
Neither one of the stated solutions work..

The one of okleinecke seems to be ok but a "./configure" is missing before the make - afterwards it seems to install. The hints given by emilianoromero dont work at all, but anyway - if you are using gentoo, you'd consider just grabbing this ebuild: http://bugs.gentoo.org/186848

Oliver
 [2010-04-17 18:09 UTC] emilianoromero at gmail dot com
Solution of okleinecke works, but it's missing a ./configure 
as gentoo at oliwel saids.
wget http://pecl.php.net/get/uploadprogress
tar -xvzf uploadprogress
cd ./uploadprogress-1.0.1
phpize
aclocal
libtoolize --force
autoheader
autoconf
./configure
make && make install

I test that with PDO_PGSQL and it works for me, but with 
PDO_INFORMIX it didnt work, and I have to use my solution, 
but with an aggregate libtoolize --force after phpize.

Regards
 [2016-11-30 18:43 UTC] cmb@php.net
-Status: Open +Status: Not a bug -Assigned To: +Assigned To: cmb
 [2016-11-30 18:43 UTC] cmb@php.net
> Sorry, just found out that this is DEFINITELY related to a gentoo phpize/libtool error. Bug report can be closed.

Fine, closing.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sat Dec 07 22:01:24 2019 UTC