php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #58955 build failure
Submitted: 2009-11-18 00:22 UTC Modified: 2011-09-21 13:13 UTC
From: colin at viebrock dot ca Assigned:
Status: Not a bug Package: ssh2 (PECL)
PHP Version: 5.3.0 OS: Linux
Private report: No CVE-ID: None
 [2009-11-18 00:22 UTC] colin at viebrock dot ca
Description:
------------
A build of version 0.11 fails for me on Debian Sid with the 
following relevant packages:

ii  libcurl4-openssl-dev             7.18.2-8lenny3           
Development files and documentation for libc
ii  openssh-blacklist                0.4.1                    
list of default blacklisted OpenSSH RSA and 
ii  openssh-blacklist-extra          0.4.1                    
list of non-default blacklisted OpenSSH RSA 
ii  openssh-client                   1:5.1p1-5                
secure shell client, an rlogin/rsh/rcp repla
ii  openssh-server                   1:5.1p1-5                
secure shell server, an rshd replacement
ii  openssl                          0.9.8g-15+lenny5         
Secure Socket Layer (SSL) binary and related
ii  openssl-blacklist                0.4.2                    
list of blacklisted OpenSSL RSA keys
ii  python-openssl                   0.7-2                    
Python wrapper around the OpenSSL library
ii  python-pyopenssl                 0.7-2                    
transitional dummy package
ii  libssh2-1                        0.18-1                   
SSH2 client-side library
ii  libssh2-1-dev                    0.18-1                   
SSH2 client-side library (development header
ii  libssl-dev                       0.9.8g-15+lenny5         
SSL development libraries, header files and 
ii  libssl0.9.8                      0.9.8g-15+lenny5         
SSL shared libraries

PHP is built from source on this machine; everything else is 
via Debian packages.

Reproduce code:
---------------
pecl install ssh2-beta

Expected result:
----------------
completed install

Actual result:
--------------
# pecl install ssh2-beta
downloading ssh2-0.11.0.tgz ...
Starting to download ssh2-0.11.0.tgz (22,884 bytes)
........done: 22,884 bytes
5 source files, building
running: phpize
Configuring for:
PHP Api Version:         20090626
Zend Module Api No:      20090626
Zend Extension Api No:   220090626
libssh2 prefix? [/usr] : 
building in /var/tmp/pear-build-root/ssh2-0.11.0
running: /tmp/pear/download/ssh2-0.11.0/configure --with-
ssh2=/usr
checking for grep that handles long lines and -e... 
/bin/grep
checking for egrep... /bin/grep -E
checking for a sed that does not truncate output... /bin/sed
checking for cc... cc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether cc accepts -g... yes
checking for cc option to accept ISO C89... none needed
checking how to run the C preprocessor... cc -E
checking for icc... no
checking for suncc... no
checking whether cc understands -c and -o together... yes
checking for system library directory... lib
checking if compiler supports -R... no
checking if compiler supports -Wl,-rpath,... yes
checking build system type... x86_64-unknown-linux-gnu
checking host system type... x86_64-unknown-linux-gnu
checking target system type... x86_64-unknown-linux-gnu
checking for PHP prefix... /usr/local
checking for PHP includes... -I/usr/local/include/php -
I/usr/local/include/php/main -I/usr/local/include/php/TSRM -
I/usr/local/include/php/Zend -I/usr/local/include/php/ext -
I/usr/local/include/php/ext/date/lib
checking for PHP extension directory... 
/usr/local/lib/php/extensions/no-debug-non-zts-20090626
checking for PHP installed headers prefix... 
/usr/local/include/php
checking if debug is enabled... no
checking if zts is enabled... no
checking for re2c... no
configure: WARNING: You will need re2c 0.13.4 or later if 
you want to regenerate PHP parsers.
checking for gawk... gawk
checking for ssh2 support... yes, shared
checking for libssh2_banner_set in -lssh2... yes
checking for libssh2_channel_forward_listen_ex in -lssh2... 
yes
checking for libssh2_userauth_hostbased_fromfile_ex in -
lssh2... yes
checking for libssh2_poll in -lssh2... yes
checking for libssh2_publickey_init in -lssh2... yes
checking for ld used by cc... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... yes
checking for /usr/bin/ld option to reload object files... -r
checking for BSD-compatible nm... /usr/bin/nm -B
checking whether ln -s works... yes
checking how to recognise dependent libraries... pass_all
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking dlfcn.h usability... yes
checking dlfcn.h presence... yes
checking for dlfcn.h... yes
checking the maximum length of command line arguments... 
32768
checking command to parse /usr/bin/nm -B output from cc 
object... ok
checking for objdir... .libs
checking for ar... ar
checking for ranlib... ranlib
checking for strip... strip
checking if cc static flag  works... yes
checking if cc supports -fno-rtti -fno-exceptions... no
checking for cc option to produce PIC... -fPIC
checking if cc PIC flag -fPIC works... yes
checking if cc supports -c -o file.o... yes
checking whether the cc linker (/usr/bin/ld -m elf_x86_64) 
supports shared libraries... yes
checking whether -lc should be explicitly linked in... no
checking dynamic linker characteristics... GNU/Linux ld.so
checking how to hardcode library paths into programs... 
immediate
checking whether stripping libraries is possible... yes
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... no

creating libtool
appending configuration tag "CXX" to libtool
configure: creating ./config.status
config.status: creating config.h
running: make
/bin/sh /var/tmp/pear-build-root/ssh2-0.11.0/libtool --
mode=compile cc  -I. -I/tmp/pear/download/ssh2-0.11.0 -
DPHP_ATOM_INC -I/var/tmp/pear-build-root/ssh2-0.11.0/include 
-I/var/tmp/pear-build-root/ssh2-0.11.0/main -
I/tmp/pear/download/ssh2-0.11.0 -I/usr/local/include/php -
I/usr/local/include/php/main -I/usr/local/include/php/TSRM -
I/usr/local/include/php/Zend -I/usr/local/include/php/ext -
I/usr/local/include/php/ext/date/lib  -DHAVE_CONFIG_H  -g -
O2   -c /tmp/pear/download/ssh2-0.11.0/ssh2.c -o ssh2.lo
mkdir .libs
 cc -I. -I/tmp/pear/download/ssh2-0.11.0 -DPHP_ATOM_INC -
I/var/tmp/pear-build-root/ssh2-0.11.0/include -
I/var/tmp/pear-build-root/ssh2-0.11.0/main -
I/tmp/pear/download/ssh2-0.11.0 -I/usr/local/include/php -
I/usr/local/include/php/main -I/usr/local/include/php/TSRM -
I/usr/local/include/php/Zend -I/usr/local/include/php/ext -
I/usr/local/include/php/ext/date/lib -DHAVE_CONFIG_H -g -O2 
-c /tmp/pear/download/ssh2-0.11.0/ssh2.c  -fPIC -DPIC -o 
.libs/ssh2.o
/tmp/pear/download/ssh2-0.11.0/ssh2.c:52: error: duplicate 
'static'
/tmp/pear/download/ssh2-0.11.0/ssh2.c: In function 
'zif_ssh2_methods_negotiated':
/tmp/pear/download/ssh2-0.11.0/ssh2.c:503: warning: passing 
argument 4 of 'add_assoc_string_ex' discards qualifiers from 
pointer target type
/tmp/pear/download/ssh2-0.11.0/ssh2.c:504: warning: passing 
argument 4 of 'add_assoc_string_ex' discards qualifiers from 
pointer target type
/tmp/pear/download/ssh2-0.11.0/ssh2.c:508: warning: passing 
argument 4 of 'add_assoc_string_ex' discards qualifiers from 
pointer target type
/tmp/pear/download/ssh2-0.11.0/ssh2.c:509: warning: passing 
argument 4 of 'add_assoc_string_ex' discards qualifiers from 
pointer target type
/tmp/pear/download/ssh2-0.11.0/ssh2.c:510: warning: passing 
argument 4 of 'add_assoc_string_ex' discards qualifiers from 
pointer target type
/tmp/pear/download/ssh2-0.11.0/ssh2.c:511: warning: passing 
argument 4 of 'add_assoc_string_ex' discards qualifiers from 
pointer target type
/tmp/pear/download/ssh2-0.11.0/ssh2.c:516: warning: passing 
argument 4 of 'add_assoc_string_ex' discards qualifiers from 
pointer target type
/tmp/pear/download/ssh2-0.11.0/ssh2.c:517: warning: passing 
argument 4 of 'add_assoc_string_ex' discards qualifiers from 
pointer target type
/tmp/pear/download/ssh2-0.11.0/ssh2.c:518: warning: passing 
argument 4 of 'add_assoc_string_ex' discards qualifiers from 
pointer target type
/tmp/pear/download/ssh2-0.11.0/ssh2.c:519: warning: passing 
argument 4 of 'add_assoc_string_ex' discards qualifiers from 
pointer target type
/tmp/pear/download/ssh2-0.11.0/ssh2.c: In function 
'zif_ssh2_publickey_add':
/tmp/pear/download/ssh2-0.11.0/ssh2.c:1045: warning: passing 
argument 1 of '_efree' discards qualifiers from pointer 
target type
/tmp/pear/download/ssh2-0.11.0/ssh2.c: In function 
'zif_ssh2_publickey_list':
/tmp/pear/download/ssh2-0.11.0/ssh2.c:1104: warning: passing 
argument 4 of 'add_assoc_stringl_ex' discards qualifiers 
from pointer target type
/tmp/pear/download/ssh2-0.11.0/ssh2.c:1105: warning: passing 
argument 4 of 'add_assoc_stringl_ex' discards qualifiers 
from pointer target type
make: *** [ssh2.lo] Error 1
ERROR: `make' failed

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-11-18 00:31 UTC] colin at viebrock dot ca
I meant to say this is a Debian Lenny box, not Sid.
 [2009-11-23 11:07 UTC] colin at viebrock dot ca
The patch listed for http://pecl.php.net/bugs/bug.php?id=16727 seems to have solved the problem ... but I'd like a developer to confirm.
 [2010-07-19 02:37 UTC] taijinjiang at hotmail dot com
/home/soft/ssh2-0.11.0/ssh2.c  -fPIC -DPIC -o .libs/ssh2.o
/home/soft/ssh2-0.11.0/ssh2.c:52: error: duplicate 'static'
/home/soft/ssh2-0.11.0/ssh2.c: In function 'zif_ssh2_methods_negotiated':
/home/soft/ssh2-0.11.0/ssh2.c:508: warning: passing argument 4 of 'add_assoc_string_ex' discards qualifiers from pointer target type
/home/soft/ssh2-0.11.0/ssh2.c:509: warning: passing argument 4 of 'add_assoc_string_ex' discards qualifiers from pointer target type
/home/soft/ssh2-0.11.0/ssh2.c:513: warning: passing argument 4 of 'add_assoc_string_ex' discards qualifiers from pointer target type
/home/soft/ssh2-0.11.0/ssh2.c:514: warning: passing argument 4 of 'add_assoc_string_ex' discards qualifiers from pointer target type
/home/soft/ssh2-0.11.0/ssh2.c:515: warning: passing argument 4 of 'add_assoc_string_ex' discards qualifiers from pointer target type
/home/soft/ssh2-0.11.0/ssh2.c:516: warning: passing argument 4 of 'add_assoc_string_ex' discards qualifiers from pointer target type
/home/soft/ssh2-0.11.0/ssh2.c:521: warning: passing argument 4 of 'add_assoc_string_ex' discards qualifiers from pointer target type
/home/soft/ssh2-0.11.0/ssh2.c:522: warning: passing argument 4 of 'add_assoc_string_ex' discards qualifiers from pointer target type
/home/soft/ssh2-0.11.0/ssh2.c:523: warning: passing argument 4 of 'add_assoc_string_ex' discards qualifiers from pointer target type
/home/soft/ssh2-0.11.0/ssh2.c:524: warning: passing argument 4 of 'add_assoc_string_ex' discards qualifiers from pointer target type
/home/soft/ssh2-0.11.0/ssh2.c: In function 'zif_ssh2_publickey_add':
/home/soft/ssh2-0.11.0/ssh2.c:1050: warning: passing argument 1 of '_efree' discards qualifiers from pointer target type
/home/soft/ssh2-0.11.0/ssh2.c: In function 'zif_ssh2_publickey_list':
/home/soft/ssh2-0.11.0/ssh2.c:1109: warning: passing argument 4 of 'add_assoc_stringl_ex' discards qualifiers from pointer target type
/home/soft/ssh2-0.11.0/ssh2.c:1110: warning: passing argument 4 of 'add_assoc_stringl_ex' discards qualifiers from pointer target type
make: *** [ssh2.lo] 错误 1
 [2011-09-21 13:13 UTC] bjori@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. Because of this, we hope you add your comments
to the existing bug instead.

Thank you for your interest in PECL.

Duplicate of bug#16727
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Tue Sep 17 12:01:27 2019 UTC