php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #58923 Requesting a PWL dict truncates the file
Submitted: 2009-10-28 08:04 UTC Modified: 2020-03-02 10:35 UTC
Votes:1
Avg. Score:4.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: nestor dot todorov at gmail dot com Assigned: cmb (profile)
Status: Not a bug Package: Enchant related
PHP Version: 5.2.10 OS: Linux 2.6.31
Private report: No CVE-ID: None
 [2009-10-28 08:04 UTC] nestor dot todorov at gmail dot com
Description:
------------
Calling enchant_broker_request_pwl_dict on a non-writable 
file triggers an error ("Couldn't open personal wordlist").

Calling the method on a writable file truncates it.


Installed providers:
zemberek 
/usr/lib/enchant/libenchant_zemberek.so

hspell
/usr/lib/enchant/libenchant_hspell.so

ispell
/usr/lib/enchant/libenchant_ispell.so

myspell
/usr/lib/enchant/libenchant_myspell.so

aspell
/usr/lib/enchant/libenchant_aspell.so

Software versions:
aspell_0.60.6-2_amd64
hunspell_1.2.8-4ubuntu2_amd64
ispell_3.1.20.0-4.5ubuntu1_amd64
hspell_1.0-4_amd64

Reproduce code:
---------------
$broker = enchant_broker_init();
$dictionary = enchant_broker_request_pwl_dict($broker, $dict_file);

var_dump($dictionary);

Expected result:
----------------
a resource representation of the custom dictionary

Actual result:
--------------
false

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2012-06-25 22:11 UTC] info at jianway dot co dot uk
Reproduced
OS: CentOS 6.2
PHP: 5.3.3
Libenchant: 1.5.x

Personal word file is truncated as described above.
 [2012-06-25 22:45 UTC] info at jianway dot co dot uk
Possibly relates to http://bugzilla.abisource.com/show_bug.cgi?id=12350
 [2012-06-27 00:16 UTC] info at jianway dot co dot uk
Installing Enchant >= 1.6 fixes bug
 [2020-03-02 10:35 UTC] cmb@php.net
-Status: Open +Status: Not a bug -Package: enchant +Package: Enchant related -Assigned To: +Assigned To: cmb
 [2020-03-02 10:35 UTC] cmb@php.net
Indeed, that has been an upstream bug, which has been fixed long
ago.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sat May 15 04:01:24 2021 UTC