|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #58899 0 parse errors occured, but thrown.
Submitted: 2009-10-17 11:07 UTC Modified: 2010-02-09 01:58 UTC
From: robert dot de dot wilde at online dot nl Assigned:
Status: Open Package: SCA_SDO (PECL)
PHP Version: 5.3.0RC4 OS: CentOS 5.x
Private report: No CVE-ID:
Have you experienced this issue?
Rate the importance of this bug to you:

 [2009-10-17 11:07 UTC] robert dot de dot wilde at online dot nl
The script gives me a fatal error. I just try to load the XML Schema example code from w3schools, but it didn't work

I tried removing whitespaces, it didn't help;

Reproduce code:
	$oXMLFactory = SDO_DAS_XML::create();
	$oXMLFactory->loadString('<?xml version="1.0"?>
															<xs:schema xmlns:xs="" xmlns="default">
																<xs:complexType name="nodeType">
															      <xs:element name="to" type="xs:string"/>
															      <xs:element name="from" type="xs:string"/>
															      <xs:element name="heading" type="xs:string"/>
															      <xs:element name="body" type="xs:string"/>
																<xs:element name="note" type="noteType"/>

Expected result:
Loading the definition;


Actual result:
Fatal error: Uncaught exception 'SDO_DAS_XML_ParserException' with message 'SDO_DAS_XML::loadString - Unable to parse the supplied xml string 0 parse error(s) occurred when parsing the string: ' in /var/www/client/some.ext/http/rows/index.php:3 Stack trace: #0 /var/www/client/some.ext/http/rows/index.php(3): SDO_DAS_XML->loadString('<?xml version="...') #1 {main} thrown in /var/www/client/some.ext/http/rows/index.php on line 3


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2010-02-09 01:58 UTC] robert dot de dot wilde at online dot nl
I think it's a bad thing no one seems to bother.
PHP Copyright © 2001-2015 The PHP Group
All rights reserved.
Last updated: Tue Oct 13 21:01:29 2015 UTC