php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #58897 installation problem
Submitted: 2009-10-16 03:56 UTC Modified: 2009-10-16 09:07 UTC
From: hasan at sertcelik dot net Assigned:
Status: Not a bug Package: pdflib (PECL)
PHP Version: 5.2.4 OS: linux ubuntu hardy
Private report: No CVE-ID: None
 [2009-10-16 03:56 UTC] hasan at sertcelik dot net
Description:
------------
configure: error: pdflib.h not found! Check the path passed to --with-pdflib=<PATH>. PATH should be the install prefix directory.



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-10-16 08:41 UTC] rjs at pdflib dot com
Not enough information was provided for us to be able
to handle this bug. Please re-read the instructions at
http://bugs.php.net/how-to-report.php

If you can provide more information, feel free to add it
to this bug and change the status back to "Open".

Thank you for your interest in PECL.


how did you call configure, where did you install PDFlib and what which path did you use with --with-pdflib.
 [2009-10-16 09:00 UTC] hasan at sertcelik dot net
root@ankara:~# pecl install pdflib
downloading pdflib-2.1.7.tgz ...
Starting to download pdflib-2.1.7.tgz (55,997 bytes)
.............done: 55,997 bytes
11 source files, building
running: phpize
Configuring for:
PHP Api Version:         20041225
Zend Module Api No:      20060613
Zend Extension Api No:   220060519
 1. path to pdflib installation? :

1-1, 'all', 'abort', or Enter to continue:
building in /var/tmp/pear-build-root/pdflib-2.1.7
running: /tmp/pear/cache/pdflib-2.1.7/configure --with-pdflib=
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for a sed that does not truncate output... /bin/sed
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking whether gcc and cc understand -c and -o together... yes
checking for system library directory... lib
checking if compiler supports -R... no
checking if compiler supports -Wl,-rpath,... yes
checking build system type... x86_64-unknown-linux-gnu
checking host system type... x86_64-unknown-linux-gnu
checking target system type... x86_64-unknown-linux-gnu
checking for PHP prefix... /usr
checking for PHP includes... -I/usr/include/php5 -I/usr/include/php5/main -I/usr/include/php5/TSRM -I/usr/include/php5/Zend -I/usr/include/php5/ext -I/usr/include/php5/ext/date/lib
checking for PHP extension directory... /usr/lib/php5/20060613
checking for PHP installed headers prefix... /usr/include/php5
checking for re2c... re2c
checking for re2c version... 0.12.1 (ok)
checking for gawk... no
checking for nawk... nawk
checking if nawk is broken... no
checking for PDFlib support... yes, shared
configure: error: pdflib.h not found! Check the path passed to --with-pdflib=<PATH>. PATH should be the install prefix directory.
ERROR: `/tmp/pear/cache/pdflib-2.1.7/configure --with-pdflib=' failed
root@ankara:~#
pdflib.h not found!
 [2009-10-16 09:07 UTC] rjs at pdflib dot com
Thank you for taking the time to write to us, but this is not
a bug.

You did not give a path where configure should find PDFlib.

You may look here:

http://www.pdflib.com/fileadmin/pdflib/pdf/support/PDFlib-in-PHP-HowTo.pdf

for more Details on how to build this extension.
 [2012-01-23 22:26 UTC] anonymous at somewhere dot com
This is because the package has moved to Horde_Pdf. While this is a case of RTFM, it is still annoying to get to the bottom of the page and not see either party knowing what they are talking about.
 [2018-08-13 13:58 UTC] gio at giombg dot com
configure: error: pdflib.h not found! Check the path passed to --with-pdflib=<PATH>. PATH should be the install prefix directory.

just try to see howto to install in all guide and don't found nothing userful

any suggestion on how to fix this non bug that is like that ??
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Jan 19 07:01:23 2020 UTC