|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #58859 max php version should be updated in package.xml
Submitted: 2009-09-14 23:37 UTC Modified: 2011-02-17 17:16 UTC
From: ppadron at w3p dot com dot br Assigned:
Status: Closed Package: rpmreader (PECL)
PHP Version: 5.2.6 OS: Ubuntu
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Bug Type:
From: ppadron at w3p dot com dot br
New email:
PHP Version: OS:


 [2009-09-14 23:37 UTC] ppadron at w3p dot com dot br
This package won't install via "pecl install" when running PHP > 5.1. This happens because it is specified in package.xml that the max PHP version supported is 5.1. Considering the date when this package was released, it kinda makes sense, but it compiles under PHP 5.2 (I have only tested with 5.2.6 and 5.2.10 though).

Reproduce code:
pecl install rpmreader-0.3

Expected result:
package installed successfully

Actual result:
pecl/rpmreader requires PHP (version >= 4.4.1, version <= 5.1.0), installed version is 5.2.6-3ubuntu4.2
No valid packages found
install failed


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2011-02-17 17:16 UTC]
Thank you for your bug report. This issue has been fixed
in the latest released version of the package, which you can download at

A new release (0.4) has been rolled out by the maintainer 
fixing this problem.
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sun Feb 25 09:01:26 2024 UTC