php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #58859 max php version should be updated in package.xml
Submitted: 2009-09-14 23:37 UTC Modified: 2011-02-17 17:16 UTC
From: ppadron at w3p dot com dot br Assigned:
Status: Closed Package: rpmreader (PECL)
PHP Version: 5.2.6 OS: Ubuntu
Private report: No CVE-ID: None
 [2009-09-14 23:37 UTC] ppadron at w3p dot com dot br
Description:
------------
This package won't install via "pecl install" when running PHP > 5.1. This happens because it is specified in package.xml that the max PHP version supported is 5.1. Considering the date when this package was released, it kinda makes sense, but it compiles under PHP 5.2 (I have only tested with 5.2.6 and 5.2.10 though).

Reproduce code:
---------------
pecl install rpmreader-0.3

Expected result:
----------------
package installed successfully

Actual result:
--------------
pecl/rpmreader requires PHP (version >= 4.4.1, version <= 5.1.0), installed version is 5.2.6-3ubuntu4.2
No valid packages found
install failed


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2011-02-17 17:16 UTC] ppadron@php.net
Thank you for your bug report. This issue has been fixed
in the latest released version of the package, which you can download at
http://pecl.php.net/get/rpmreader

A new release (0.4) has been rolled out by the maintainer 
fixing this problem.

http://pecl.php.net/package-changelog.php?
package=rpmreader&release=0.4
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Thu Sep 23 10:03:34 2021 UTC