php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #58847 Cannot Find Certain Array Elements from getMulti() when using Binary Protocol
Submitted: 2009-09-01 14:03 UTC Modified: 2012-03-07 17:21 UTC
From: jmy at morgontech dot com Assigned: andrei (profile)
Status: Closed Package: memcached (PECL)
PHP Version: 5.3.0 OS: CentOS 5.3 / Kernel 2.6.18-128
Private report: No CVE-ID: None
 [2009-09-01 14:03 UTC] jmy at morgontech dot com
Description:
------------
In my application, I'm attempting to retrieve a specific list of keys. When I retrieve this list using getMulti(), many of its elements cannot be accessed directly, even though they clearly exist when print_r()'ing the result array.

This seems to only happen when using Memcache, and doesn't seem to be (only) an issue with PHP's array handling or potential key limitations. If I set an array using the same elements, I can retrieve them at will.

Finally, this only seems to happen when enabling the Binary protocol. I enabled this in hopes of getting additional speed out of my application, and would really like to be able to use it! :)

Reproduce code:
---------------
Honoring '> 20 line' request:
http://pastebin.com/f79f01c2a

Expected result:
----------------
Expected result is to have all elements in the getMulti result array be directly accessible.
For this example, the expected result is for all keys to be marked 'Found'.

Actual result:
--------------
[snip]
GTID:%09%5d%3abn%5c%1e9%7e%0a            Found: "My Key is GTID:%09%5d%3abn%5c%1e9%7e%0a!"
GTID:%09%5d%3bhe)j3p%01                  NOT Found
GTID:%09%5d%3a%15%18*iN%0er              NOT Found
GTID:%09%5d%3a%15%18*iAss                NOT Found
GTID:%09%5d%3a%15%18*iNe4X6z-17t         Found: "My Key is GTID:%09%5d%3a%15%18*iNe4X6z-17t!"

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-09-01 14:05 UTC] jmy at morgontech dot com
[Fixing PHP Version to 5.3.0, since PECL does not have that as an option]
 [2009-12-13 14:40 UTC] tricky dot pecl at luuseri dot com
This seems to be a duplicate of #16959, please check that out.
 [2009-12-13 18:59 UTC] jmy at morgontech dot com
Er, not to be too pedantic, but Bug #16959 was made after mine, so I can't be the dupe ;)
 [2011-08-28 20:55 UTC] info at takakurajutaku dot com
http://www.pillscity.net/ valtrex 311742 http://www.findyourpills.net/ colchicine 8354
 [2011-09-14 19:42 UTC] emao at bb dot cosmos dot ne dot jp
http://www.pricechampion.net/ accutane 31340 http://www.topratedpills.net/ wellbutrin topamax weight loss 359759
 [2012-03-07 17:21 UTC] andrei@php.net
Closing because of age. Please try version 2.0.1 and reopen if this still occurs.
 [2012-03-07 17:21 UTC] andrei@php.net
-Status: Open +Status: Closed -Assigned To: +Assigned To: andrei
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Aug 07 13:01:24 2020 UTC